0

$ sudo apt-get install sqliteman* sqlite3*

gives me a display that includes this:

...
Recommended packages:
  bacula-sd-mysql bacula-sd-tools cl-sql-backend ada-reference-manual
  gdb-minimal php-http-oauth
The following NEW packages will be installed:
  ada-reference-manual-2005 akonadi-backend-mysql akonadi-backend-sqlite
  akonadi-server aolserver4-core aolserver4-daemon aolserver4-doc
  aolserver4-nssqlite3 apache2 apache2-bin apache2-data autoconf automake
...
  texlive-xetex tidy tinymce tipa tk8.5 tntdb-sqlite4 tree tzdata-java ulogd
  ulogd-sqlite3 ulogd2 ulogd2-sqlite3 uwsgi-core uwsgi-plugin-sqlite3 vim
  vim-addon-manager vim-runtime wx-common wx2.8-headers wxsqlite3-2.8-dbg
  wxsqlite3-doc zabbix-proxy-sqlite3 zend-framework zend-framework-bin
...
0 upgraded, 797 newly installed, 0 to remove and 0 not upgraded.
Need to get 1 329 MB of archives.
After this operation, 3 926 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

Checking the list I see among others 'TeX, ruby, r-cran, php. openjdk, ocaml, mysql, mono, lua, libreoffice, libjs, libghc, latex, gnustep, gcc-4.6, autotools, bacula. apache2, aolserver, ...'

This list seems so overly long and content-rich that I said No for that install.

Anyone with insight here?

All I want is to get "up and running" on sqlite3 (and nothing else).

I'm a bit of a beginner on SQL,
but see the usefulness both in private projects and at work.


In the end, the basic question:
Is there some way to reduce that list to a more reasonable one?

5
  • Are you sure that you want to use the '*' character on the ends of the packages that you are trying to install? – Charles Green Jul 18 '14 at 17:53
  • As you can see in a comment on @asish 's answer, I expected it to add three more packages. Need to check up what this actually does. Unless you have a hint? ;-) – Hannu Jul 18 '14 at 18:14
  • The '*' is a wildcard character - look for everything beginning with sqlite3... – Charles Green Jul 18 '14 at 18:18
  • Yes? That was what I expected too! grep ^sqlite3 TheList | tr '\n' ' ' | sed -re 's/ /, /g' -> sqlite3, sqlite3-doc, sqlite3-pcre, and sqliteman, sqliteman-doc, for the second package selection -- out of my saved list. – Hannu Jul 18 '14 at 18:23
  • $ ls -l sql* -> ls: cannot access sql*: No such file or directory -- no bash globbing adding stuff either. – Hannu Jul 18 '14 at 18:27
3

The "*" is the problem here. It selects too many unwanted packages and their dependencies.

Issue a command only as below:

sudo apt-get install sqliteman sqlite3
1
  • Hmm... That was news for me, I expected these to just add the *-doc packages. sudo apt-get install sqliteman sqliteman-doc sqlite3 sqlite3-doc sqlite3-pcre -> Need to get 4 689 kB of archives.\n After this operation, 15,7 MB of additional disk space will be used.\n Thanks – Hannu Jul 18 '14 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.