1


While going through my compiz settings, I noticed, that windows decarator is off, and I clicked to turn it on - then clicked yes, before I've read that this will turn off unity.

I tried reenabling it using steps like here:

and some others, but this doesn't help.

Unity supported command confirms, that it is supported on my machine. My system is Ubuntu 14.04. Currently I can see that Unity is enabled in ccsm settings (and decorator disabled), but I have no launcher, no upper bar, no side bar, no windows title bar, nothing. Just the desktop. Of course I tried restaring my computer, pluging it off and on again, etc ;)

| improve this question | | | | |
0

I also tried to have fun with compiz and the same happened. Here is what I did:

If you see your desktop like I did, then you can make a link that opens a Gnome Terminal.

From within the Console mode(Ctrl+Alt+F1), do the following:

cd ~/Desktop/
ln -s /usr/bin/gnome-terminal gnome-terminal

In the Console mode you still won't be able to enable Unity, unless there is a way to point to the Xserver. [Edit] oh "export DISPLAY=:0" does just that, but you noted that the answers in the linked question didn't help, so starting to doubt if this answer will.

IIRC, from the desktop launched Gnome Terminal do:

unity-reset
| improve this answer | | | | |
  • When I started ccsm from desktop shortcut ubuntu-unity plugin settings were a bit different, and enabling it worked! Not sure if Deleting settings helped as well, since the config files I had vere empty. Sitll it's probably recommended to run find .[^.]* -name \*.unity\* -o -name \*compiz\* -exec rm -R \{\} \; before. :) Thanks a lot! :) – Zbyszek M. Jul 19 '14 at 10:50
0

In unix systems, application settings are stored as hidden files in your home directory. Hidden files are files whose name start with ".". You can see those files by pressing Ctrl-H in the file manager or "ls -a" in the terminal.

When you mess something with your settings, the simplest solution is to remove the settings to have it reset to factory default. To do so for compiz/unity, open a terminal (Ctrl-Alt-T) then type the following command:

find .[^.]* -name \*.unity\* -o -name \*compiz\* -exec rm -R \{\} \;

This will remove any file or folder whose name contain either unity or compiz from any hidden file in the current directory. When you open a terminal, the current directory should be your home directory.

| improve this answer | | | | |
  • When I started ccsm from desktop shortcut ubuntu-unity plugin settings were a bit different, and enabling it worked! Not sure if Deleting settings helped as well, since the config files I had vere empty. Sitll it's probably recommended to run find .[^.]* -name *.unity* -o -name *compiz* -exec rm -R \{\} \; before. :) Thanks a lot! :) EDIT: Shame I can't mark both answers as a resolution. – Zbyszek M. Jul 19 '14 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.