I initially installed Ubuntu 11.04 with an encrypted file system (from the alternate install CD: Guided Partitioning, LVM encrypted). Now I wanted to change this setup to have my root file system on an unencrypted partition.

I had the following setup before:

/dev/mapper/my-root on / type ext4 (rw,noatime,errors=remount-ro,commit=0,commit=0)
/dev/sda1 on /boot type ext2 (rw,noatime)
  • I backed up /, reformatted /dev/sda5 (which had contained the encrypted LVM device) to an ext3 partition, and restored / to that partition.
  • I edited /etc/fstab, removed the line /dev/mapper/my-root / ..., and added the line: /dev/sda5 / ext3 noatime,rw,errors=remount-ro,commit=0 0 1
  • I edited /etc/crypttab, and commented out the single entry.

On reboot, I get the grub screen as usual, but then I get the message cryptsetup:evms_activate is not available, waiting for encrypted source device.

I tried reinstalling Grub2 using a LiveCD with the ChRoot method, but that didn't make any difference.

Why is Ubuntu still searching for an encrypted device?


I somehow "fixed" it - however, I don't know for sure, which of the following actions was responsible:

I chrooted again, then I ran

dpkg-reconfigure grub-pc
dpkg-reconfigure linux-image-2.6.38-8-generic

grub-install /dev/sda 
      (these last two steps I had already done before without success)

Also, I completely removed /etc/crypttab now (previously, I had only commented the line).

The error is gone now, but I would prefer to accept an answer which explains what happened here, and how to solve the problem a little bit less "chaotically" :-)

  • Fixing /etc/crypttab was the key! – user17007 Aug 4 '12 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.