0

I am using Ubuntu 14.04. I have php installed. When I check phpinfo() from browser I get 5.5.9. But when I check from command line, I get 5.3.28. How can I make the command line php also to 5.5.9 ? i google and could find that this is because php cli is using a different php.ini file. Please guide me to upgrade this to 5.5.9. Thanks

  • Could you post the command line you executed and the whereis php output? – Lety Jul 18 '14 at 22:08
1

The php command line is located in php5-cli package (apt-cache policy php5-cli), but since 5.3.28 has never been a part of Ubuntu, so I suspect that you have a local (compiled from sources) installation of php CLI probably in /usr/local.

  • you are correct @oerdnj. I manually removed the php from /usr/local/bin and then installed php5-cli in the normal way. Now I have php 5.5.9 in command line and browser – GBRocks Jul 21 '14 at 7:01
  • @GBRocks Please mark your question as answered then. – oerdnj Jul 21 '14 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.