I tried to install sqldeveloper by following way:

Download SQL Developer from Oracle website (I chose Other Platforms download).

Extract file to /opt:

sudo unzip sqldeveloper-*-no-jre.zip -d /opt/
sudo chmod +x /opt/sqldeveloper/sqldeveloper.sh
Linking over an in-path launcher for Oracle SQL Developer:

sudo ln -s /opt/sqldeveloper/sqldeveloper.sh /usr/local/bin/sqldeveloper
Edit /usr/local/bin/sqldeveloper.sh replace it's content to:

cd /opt/sqldeveloper/sqldeveloper/bin
./sqldeveloper "$@"
Run SQL Developer:


But it shows next output:

nazar@lelyak-desktop:/opt/sqldeveloper⟫ ./sqldeveloper.sh 

 Oracle SQL Developer
 Copyright (c) 1997, 2014, Oracle and/or its affiliates. All rights reserved.    

 LOAD TIME : 401#
# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f3b2dcacbe0, pid=20351, tid=139892273444608
# JRE version: Java(TM) SE Runtime Environment (7.0_65-b17) (build 1.7.0_65-b17)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.65-b04 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  0x00007f3b2dcacbe0
# Core dump written. Default location: /opt/sqldeveloper/sqldeveloper/bin/core or core.20351
# An error report file with more information is saved as:
# /tmp/hs_err_pid20351.log
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
/opt/sqldeveloper/sqldeveloper/bin/../../ide/bin/launcher.sh: line 1193: 20351 Aborted                 (core dumped) ${JAVA} "${APP_VM_OPTS[@]}" ${APP_ENV_VARS} -classpath ${APP_CLASSPATH} ${APP_MAIN_CLASS} "${APP_APP_OPTS[@]}"
134 nazar@lelyak-desktop:/opt/sqldeveloper⟫ java -version
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

Here is content of /tmp/hs_err_pid20351.log

How to solve this trouble?


Also affected but found solution here.

Solution is simple, before launch sh sqldeveloper.sh unset environment variable GNOME_DESKTOP_SESSION_ID or you can create another launcher.sh like this:
unset GNOME_DESKTOP_SESSION_ID sh sqldeveloper.sh


I am getting the same problem and have not yet resolved the issue. I found this post with suggestions.

1) Install OpenJDK

sudo apt-get install openjdk-7-jdk

2) Open the configuration file

vim ~/.sqldeveloper/4.0.0/product.conf

3) Change


I had to remove OpenJDK and reinstall for it to work for me. I think there was something with the links.

SetJavaHome /usr/lib/jvm/java-7-openjdk-amd64
  • it doesn't work for me. I reinstalled open-jdk, too. – catch23 Aug 27 '14 at 17:07
  • @nazar_art did you set the deault jvm? – Kevin Aug 27 '14 at 17:45
  • Yes, of course. I did it. Reinstall open JDK and tried again. It keep throwing the same error. – catch23 Aug 28 '14 at 8:40

For me, I just had to set SetJavaHome entry with the path for the JDK in the ~/.sqldeveloper/4.1.0/product.conf and it worked like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.