4

I have a Vaio laptop, where the touchpad contains the two buttons (primary and secondary). This means you have to click your touchpad to click on things. The buttons are not separate to the touchpad.

This is a problem because I normally have two fingers on the pad at a time, one to move the cursor across the screen, and one to click on things. But in Ubuntu, two fingers means scrolling, so if one uses two fingers on the touchpad, the cursor stops moving.

I have tried:

Section "InputClass" MatchIsTouchpad "on" Identifier "Touchpads" Driver "mtrack" EndSection

into my /etc/X11/xorg.conf file but that completely disables the touchpad. Might I not have mtrack installed? How do I find out if I have the right driver?

An acceptable solution is to disable a small area at the bottom of the trackpad (preferably bottom left), but I don't know how to do this?

Thanks

  • What's the output of synclient? (Preferably, add it to a pastebin and share the URL.) – edwin Jul 21 '14 at 20:10
  • I've posted it in the question – Cobbles Jul 21 '14 at 21:12
0

There is an alternative touchpad driver specifically crafted for "true" multitouch capable devices.

forked touchpad driver by bluedragonX

The link to the deb file download seems broken. But its available in the ubuntu universe repositories if you have them enabled under the name xserver-xorg-input-mtrack Its quite discussed in the ubuntu forums

It allowed a resting finger when i tried it on my MacBook touchpad after some tweaking.

The Synaptics people seem to have been working on a fix as well. The bottom Edge feature in synclient is a result of this.

Its not working properly according to the launchpad bug but It seems to have been fixed upstream and working in synaptics 1.7.6

Created a file under /etc/X11/xorg.conf with the following settings:

 Section "InputClass"
     MatchIsTouchpad "on"
     Identifier      "Touchpads"
     Driver          "mtrack"
     Option          "Sensitivity" "0.55"
     Option      "FingerHigh" "12"
     Option      "FingerLow" "1"
     Option          "IgnoreThumb" "true"
     Option          "IgnorePalm" "true"
     Option          "TapButton1" "0"
     Option          "TapButton2" "0"
     Option          "TapButton3" "0"
     Option          "TapButton4" "0"
     Option          "ClickFinger1" "1"
     Option          "ClickFinger2" "3"
     Option          "ClickFinger3" "3"
     Option          "ButtonMoveEmulate" "false"
     Option      "ButtonIntegrated" "true"
     Option          "ClickTime" "25"
     Option          "BottomEdge" "25"
     Option      "SwipeLeftButton" "8"
     Option      "SwipeRightButton" "9"
     Option      "SwipeUpButton" "0"
     Option      "SwipeDownButton" "0"
     Option      "ScrollDistance" "75"

 EndSection

Since there are many different touch pads you might need to tweak these settings initially.

  • Thank you for looking into this, but the link to dev.fatalmachine.org/xf86-input-mtrack/ubuntu is broken, do you know where I can find the deb? – Cobbles Jul 22 '14 at 15:51
  • @Cobbles I’ve updated my answer with a different location for the deb – tomodachi Jul 24 '14 at 7:56
  • I tried, but that didn't change anything. I also tried different driver configurations, but still nothing. How can I change the bottom edge feature? – Cobbles Jul 25 '14 at 8:14
  • Added the working xorg.conf I use for the mtrack driver. – tomodachi Jul 27 '14 at 20:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.