18

This happens now and then and after a restart it works. No clue as to what causes this. When this happened earlier I would search for Terminal in Dash and launch. But today, even that does not work.

I have tried the solutions posted in the following posts without any luck.

I am going to restart lightdm first to see if that helps and if not I will restart my laptop.

I look forward to your suggestions on what else I could try for this is sure to recur.

  • 1
    Restarting lightdm worked. – eshwar Jul 17 '14 at 10:23
  • 1
    You should add your comment as answer! – Radu Rădeanu Jul 17 '14 at 13:54
  • I dont believe restarting lightdm is the right solution. – eshwar Jul 18 '14 at 10:11
  • experienced the same problem in 14.04 over a long period. Seems to have disappeared jan 2015 after updating. – davidkonrad Jan 27 '15 at 13:25
18

I have also faced that type of problem earlier and initially used to restart.

But now any type of such problem, then by using following command:

kill -9 -1

This will kill processes and return to login screen, then after login all works well & successfully.

  • 1
    I hate having to do this every time I log in. Is there a way to make it more permanent? – Jake Aug 27 '15 at 9:57
4

It's a confirmed bug. https://bugs.launchpad.net/ubuntu/+source/gnome-terminal/+bug/1292113

I've had the same thing happening. Sometimes, after a minute or two of doing something else, a screen full of terminals I attempted to open with a series of frustrated ctrl+alt+ts blows up in my workspace.

If you go to launchpad, and confirm that it also affects you, it raises the priority of the bug, meaning it would be more likely to be fixed sooner.

  • The resolution of this bug is: fix released. I have had the same problem on 14.10 just now... – Vogel612 Mar 12 '15 at 9:56
2

If (like me) you use gnome-session-fallback, executing:

pkill gnome-panel

should resolve this.

2

I had the same issue and tried to Reset All(keyboard shortcuts) and it worked charm.

process:

Go to Settings->Devices->Keyboard Shortcuts-> Reset All

it worked like charm

  • I didnt add "thank you", that was a real answer, you bot! – Joyy Jan 11 '18 at 9:39
  • Could you please expand on this answer by editing it and include how you did the reset all? (From the terminal, from a C function library, from a menu, ...) as it is now, your answer isn't very clear. – Fabby Jan 11 '18 at 10:30
2

I had this problem - Alt+Ctrl+T stopped working - and what solved it to me was this answer:

https://askubuntu.com/a/67372

after doing kill -9 -1 as suggested in Pandya's answer, I noticed an error about monitor configuration.

And so I reached the above answer that instructs to delete /home/__username__/.config/monitors.xml

Before this I couldn't switch language as well.

1

Instead of using Ctrl + Alt + T as the shortcut, you can redefine Alt + T as the shortcut in the Settings > Keyboard > Launchers settings to replace the old Launch setting for Launch terminal (this is not to set up a new customized short key). It seems a bug and may also because there is a conflict. This works for me at least.

-3

Go Settings->Keyboard->Custom Shortcuts

enter image description here

  • 1
    This was suggested in the posts I cited in my question and tried by me already. – eshwar Jul 18 '14 at 10:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.