63

This question already has an answer here:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

This is a familiar message to everyone that uses Virtual Box. This "bug" has been popping up every few months at least since 11.10. I got it today for the first time on 14.04 and unfortunately the classical solution of re-installing virtualbox-dkms is not having any effect:

sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove virtualbox-dkms
sudo apt-get install virtualbox-dkms

What could be the reason for this old fix to fail?

Update: In the comments user bain makes reference to an old thread that apparently reports to the same problem. While the error message is similar, on Ubuntu 14.04 this issue seems to have a different nature, unrelated to the virtualbox-dkms package. For instance, on Ubuntu 14.04 the virtualbox package is up to date:

$ sudo apt-cache policy virtualbox
virtualbox:
  Installed: 4.3.10-dfsg-1
  Candidate: 4.3.10-dfsg-1
  Version table:
 *** 4.3.10-dfsg-1 0
        500 http://de.archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages
        100 /var/lib/dpkg/status

marked as duplicate by bain, Eric Carvalho, karel, Panther, Radu Rădeanu Jul 23 '14 at 0:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Try the answers in the linked question. Make sure all updates are in place (apt-get update && apt-get dist-upgrade) then uninstall virtualbox (apt-get purge virtualbox*) and re-install. – bain Jul 17 '14 at 9:39
  • 2
    Hi bain. The question you link is over 3 years old, referring to older Ubuntu versions where this problem had different solutions. – Luís de Sousa Jul 17 '14 at 12:41
  • 2
    Please reopen this question. Right now there is no viable solution for Ubuntu 14.04.Thank you. – Luís de Sousa Jan 16 '15 at 14:53
  • 1
    @LuísdeSousa I fail to see the reasoning in reopening this. If this is a bug that needs addressed, file it as a bug, and keep this closed as a thousand open questions with no resolution is detrimental - assuming that a fix comes through then perhaps we can reopen it then. – Thomas Ward Jan 16 '15 at 15:44
  • 2
    That is a great logic you have there Thomas. If the question remains closed how can a new fix be posted by someone else? – Luís de Sousa Jan 17 '15 at 8:04
87

The fix for 14.04 is indeed different, but not that different:

sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove --purge virtualbox-dkms
sudo apt-get install virtualbox-dkms

The install virtualbox-dkms command was actually failing applying the 13.10 fix. By fully purging the package things got back to normal.

Update [17-01-2015]: In the latest iteration of this bug a restart to the system is required between the apt-get remove command and the second apt-get install.

Update [07-02-2016]: This fix is reportedly functional on Ubuntu 15.10.

Update [29-09-2016]: This fix is also functional on Ubuntu 16.04.

  • Are these commands run in the VM or on the host? – Dave Jun 11 '15 at 21:37
  • 6
    It is all in the host. This is a problem with VirtualBox itself. – Luís de Sousa Jun 12 '15 at 8:59
  • Does not work for me. Error during installation of virtualbox-dkms: ERROR (dkms apport): kernel package linux-headers-4.0.9-040009-generic is not supported... – hako Aug 27 '15 at 12:43
  • 1
    Overkill, if you have dkms installed you were probably running virtualbox and just need to rebuild the kernel module. See suggested duplicates at the top. – Constantin Jul 5 '16 at 15:20
  • 6
    For me the REAL problem turned out to be boot-efi which is the default on the ubuntu/kubuntu-14.04 install. After removing virtualbox-dkms & reinstalling it, I got a pop-up about boot-efi running in "secure" mode will not allow these drivers to load.....soooo, the thing rebooted in MOK, and with MOK I DISABLED efi-boot's secure mode. ALL IS NOW WELL. – Eric Sep 24 '16 at 2:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.