19

How do I reset the font settings - actual font and size - to their default?

(I changed some values in System->Preferences->Appearance->Fonts)

This is particularly important with the new Ubuntu font in Maverick - for instance I'm interested to see what the default settings are.

19

Ubuntu 15.10 and before

To reset the customization of gnome fonts done using System -> Preferences -> Appearance -> Fonts use the following commands.

Basically these commands remove the customization by deleting the user instance of the gconf keys in which case the environment falls back to system defaults.

gconftool-2 --unset /desktop/gnome/interface/font_name
gconftool-2 --unset /desktop/gnome/interface/document_font_name
gconftool-2 --unset /desktop/gnome/interface/monospace_font_name
gconftool-2 --unset /apps/metacity/general/titlebar_font
gconftool-2 --unset /apps/nautilus/preferences/desktop_font 

Though the key identifiers end with name (at least in the first three instances) what is stored against them is the complete font spec (like family/font name, size, style etc).

Since these keys are stored inside your home directory they take effect in all ubuntu installations that share the home partition. The .gconf directory inside your home directory is where all this info is stored.

  1. ~/.gconf/desktop/gnome/interface/%gconf.xml stores the info for
    • /desktop/gnome/interface/font_name
    • /desktop/gnome/interface/document_font_name
    • /desktop/gnome/interface/monospace_font_name
  2. ~/.gconf/apps/metacity/general/%gconf.xml stores /apps/metacity/general/titlebar_font
  3. ~/.gconf/apps/nautilus/preferences/%gconf.xml stores /apps/nautilus/preferences/desktop_font

So a crude way to reset the font info could be to temporarily rename/move these files. However this should be done when the user's gnome session is not active (thus from a tty session a la Ctrl+Alt+F1)

Of course these files have other keys in the same category that have nothing to do with font properties so moving the entire file would mean that the customizations for those are also lost. The way to deal key-wise is using gconftool-2 as mentioned above.

  • I wonder how size information is linked to this. Unsetting the gconf keys seems to reset this as well, but I can't see it stored anywhere! – 8128 Oct 1 '10 at 8:54
  • 1
    Good point. I have edited my answer to clarify this. – koushik Oct 1 '10 at 9:31
22
+500

Ubuntu 16.04 and after

gconftool-2 has been superseeded by gsettings on Ubuntu 16.04+ and in other GNOME based systems.

Nowadays you can simply run the following in a terminal window to reset all your desktop font settings:

gsettings reset org.gnome.desktop.interface font-name
gsettings reset org.gnome.desktop.interface document-font-name
gsettings reset org.gnome.desktop.interface monospace-font-name
gsettings reset org.gnome.desktop.wm.preferences titlebar-font
gsettings reset org.gnome.nautilus.desktop font
gsettings reset org.gnome.desktop.interface text-scaling-factor

Hope it helps.

3

Copy and paste gconf-watcher into a file on your PC called gconf-watcher. Chmod it to executable. Run it in Terminal and leave it running.

Change each setting in in SystemPreferencesAppearanceFonts. Look at gconf-watcher's output to find out where it's stored in the gconf tree.

Now install gconf-editor. It looks and works a bit like the Windows Registry Editor. Use it to "unset" the relevant values. Know that "unset" really means "reset".

By the way, if I may ask, why is it that you'd like to reset the settings?

2

To change settings on Gnome-3 you can use gsettings .

To reset all the fonts for an user, you type these commands on the user terminal :

gsettings reset org.gnome.desktop.interface monospace-font-name 

gsettings reset org.gnome.desktop.interface document-font-name

gsettings reset org.gnome.desktop.interface font-name 

gsettings reset org.gnome.desktop.wm.preferences titlebar-font 

For the scaling factor this one :

gsettings reset org.gnome.desktop.interface text-scaling-factor

To get the current configuration for each settings replace "reset" with "get" .

You can also do it with GUI by running dconf-editor .

1

Here's a screenshot from a UbuntuGnome 17.04 Live Disc. I installed Mate and Cinnamon Desktiop and noticed some changed fonts when I was using Gnome. So I used the ISO to take a screenshot and change the settings using the gnome tweak tool.

enter image description here

1

Though the answers are pretty upto-date and workable for GNOME3, there is one caveat and that is even when with using gsettings reset ... or gnome-tweak-tools' restore default button, you may not actually get the default fonts defined by the distribution. For example, Ubuntu (with Unity DE) comes with Ubuntu font as default interface font, but if you install another DE on top of this it can change this default settings.

The values for default fonts actually come from gschema files in /usr/share/glib-2.0/schemas directory. When we install a desktop environment metapackage, it provides overrides file to change these defaults.

If this kind of things happen, you need to manually revert back the default by writing a custom gschema override file.

The override files for each GNOME variants

For each cases, create an override file with this name /usr/share/glib-2.0/schemas/99_default_font_settings.gschema.override file and fill it with the following contents

Ubuntu with Unity

[org.gnome.desktop.interface]
font-name="Ubuntu 11"
monospace-font-name="Ubuntu Mono 13"

[org.gnome.desktop.wm.preferences]
titlebar-font='Ubuntu Bold 11'

Ubuntu with GNOME3

[org.gnome.desktop.interface]
font-name="Cantarell 11"
monospace-font-name="Ubuntu Mono 13"

[org.gnome.desktop.wm.preferences]
titlebar-font='Cantarell Bold 11'

Ubuntu MATE

[org.gnome.desktop.interface]
document-font-name='Ubuntu 11'
font-name='Ubuntu 11'
monospace-font-name='Ubuntu Mono 13'

[org.gnome.desktop.wm.preferences]
titlebar-font='Ubuntu Bold 11'

Once the file is saved, use this command to compile the schemas

sudo glib-compile-schemas /usr/share/glib-2.0/schemas

Then any of the above methods can be used to reset to the default set by you.

Alternatively, if you've installed GNOME environment on Ubuntu, removed ubuntu-gnome-default-settings package to get back the ubuntu defaults. MATE's package is ubuntu-mate-default-settings. If you happen to have Ubuntu GNOME as default and installed ubuntu unity, removed ubuntu-settings package.

Hope this will be helpful to some extent.

0

I refer to starkus here below - for this pretty window you need to install the package gnome-tweak-tools.

sudo apt-get install gnome-tweak-tools

sudo reboot

Then there you can set the fonts in "Schriften" resp. in "fonts".

After changed fonts-settings, then reboot again to get results system-wide.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.