I have tried to install xrdp on Ubuntu using apt-get install xrdp, but have run into issues similar to other users such as listed in these posts:

How can I install xrdp easily and robustly?

3 Answers 3


I use the scareygliders script to install XRDP as it is more stable than the default ubuntu xrdp package and also gives you copy and paste functionality between the host and client.

However, I had issues setting up XRDP with lubuntu and standard ubuntu desktops so I eventually went with xubuntu desktop:

sudo apt-get update
sudo apt-get upgrade
# I'm not sure if xvfb is required, but have installed it just to be sure
sudo apt-get install xubuntu-desktop xfce4 xvfb 

git clone https://github.com/scarygliders/X11RDP-o-Matic.git
cd X11RDP-o-Matic
sudo ./X11rdp-o-matic.sh --justdoit
echo xfce4-session >~/.xsession
# if screensaver hogs the cpu
echo 'mode: off' > ~/.xscreensaver
  • just a warning to everyone: X11rdp-o-matic.sh --justdoit takes about 20 minutes to run
    – jcollum
    Aug 26, 2014 at 21:29
  • It does take a while to build. I raised a request to be able to download pre-built binary packages. See github.com/scarygliders/X11RDP-o-Matic/issues/39 for more info. Feel free to add your +1 to the issue ;)
    – Chris Snow
    Aug 26, 2014 at 21:37
  • the x11rdpomatic config script puts startxfce4 into the .xsession file, are you sure that xfce4-session is better? I can't get either to work with Ubuntu 14.04 though.
    – jcollum
    Aug 27, 2014 at 17:28
  • When you say it doesn't work, what is happening? Do you just get a black screen?
    – Chris Snow
    Aug 27, 2014 at 18:28
  • I got a message that said "login failed, giving up" etc. I'm having better luck with TightVNC and digitalocean.com/community/tutorials/…
    – jcollum
    Aug 27, 2014 at 18:45

To have xrdp working with ubuntu 14.04, you need to specify an alternate desktop. In order to have a working xrdp install, perform the following actions

  1. install xrdp (sudo apt-get install xrdp)
  2. install alternate desktop (in this example, let's say you want to install xfce),so you would type in a terminalsudo apt-get install xfce4
  3. Finally, you have to tell xrdp that you want to use xfce, so from a terminal session, you type the following command echo xfce4-session >~/.xsession
  4. Try to connect and you should be good to go

You can find detailed instruction via this link. If you do not like xfce; you can install other desktop alternative such as LXDE,Mate-desktop,kde....


I did it this way - coming from many different sources and try and error - but now it even works through Microsoft RD client on my iOS iPad 2 - fun!

Windows: I did install Windows 10 Pro Hyper V I did install virtual machine first generation - Ubuntu 14.04 LTS

Ubuntu: I did install xubuntu-desktop (for xfce4 which works - I do not care for my taste if I like or not - it works!) I did install xrde I did create a remote user I did grant sudo group to it I did create with sudo rights via vi a .xsession file (like others) in the home directory of the created remote user I made the .xsession file being able to execute via chmod in the home directory of that created remote user But - and that I only found once - I did start my .xsession file first with:

#!/usr/bin/env bash

I did not use echo ...

I entered via vi line two:


After that I did a restart of the virtual Ubuntu machine

And after the restart I was able to go to the IP of the virtual Ubuntu with the remote user created ending in a running graphical xfce4 session in the out of the box Microsoft Remote Desktop Connection without that grey screen.

I was so lucky and proud with all tha reading which I tried myself not getting a satisfying result like others with blank/grey screens and doing a combination like that from different sources myself running it as RDP session from Windows 10 or - as already written - through my iPad 2 that I like to share my experiences here with others helping me getting to this point - thanks to all!

  • xrde is typo - xrdp is correct
    – Dirk
    Feb 29, 2016 at 17:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .