1

I would like to turn my laptop (Ubuntu 14.04 - Trusty) into a wireless hotspot. So i linked my laptop to my router with an Ethernet cable, I went into System settings > Network > Wireless. I selected my router and cliked on "Use as a hotspot". The hotspot was created indeed. Now I want to change the Network name and the security key but I cant find a way to do that . It seems that those inforations are like hardened and no settings button is offered. How can I do that, using the GUI or command line, anything that works?


EDIT 1

When my wireless hotspot is created, there is not settings access to it. The SSID is my computer domain ( me@my_domain ). The screen looks like: Network Name my_domain Security Type WEP Security key xxxxxxx

No configuation button is provided.

3

Ok. I assume you mean you are connecting into Ubuntu via a network cable and then want to use your wireless card to serve internet to other devices, sounds like you dont have a wireless router. This can actually be done pretty easily, not sure about other versions, but definitely in 14.04 and 14.10.

  1. Disable WIFI and plug in an internet cable to your laptop so that your Ubuntu is connect to a wired internet and wireless is disabled.

  2. Go to Network Icon on top panel -> Edit Connections …, then click the Add button in the pop-up window.

  3. Choose Wi-Fi from the drop-down menu when you’re asked to choose a connection type

In next window

  1. Type in a connection name. The name will be used later. We will call it hotspot as example.

  2. Type in a SSID 

  3. Select mode: Infrastructure 

  4. Device MAC address: select your wireless card from drop-down menu.

  5. Go to Wi-Fi Security tab, select security type WPA & WPA2 Personal and set a password.

  6. Go to IPv4 Settings tab, from Method drop-down box select Shared to other computers.

When done, click the save button.

After above steps, a configuration file was created under /etc/NetworkManager/system-connections directory. File name is same to the connection name you typed in step 4.

Now press Ctrl+Alt+T on keyboard to open terminal. When it opens, paste the commands below and hit enter to edit the configuration file:

 nano /etc/NetworkManager/system-connections/hotspot

Replace hotspot with the connection name you actually used

When the file opens, find the line

 mode=infrastructure

and change it to

 mode=ap. 

Finally save the file.

When everything’s done, enable WIFI from Network Manager icon on the panel. It should automatically connect to the hotspot you created. If not, select “Connect to Hidden Wi-Fi Network …” and select it from the drop-down box.

You can now connect any other device via wireless, but the Ubuntu machine will need to keep it's wired connection.

Edit:I just seen you say your card does not support ap, so this probably will not work.

Works for me on my broadcom though

0

bottom left corner of network windows have option button.

where you can edit ssid, wireless security and more.

If stuck anywhere then visit this step by step tutorial.

http://thenewbieblog.wordpress.com/2012/05/01/wifi-hotspot-setup-on-ubuntu/

  • This is true for the Wired tab, the options button is located on the bottom right corner. However what I want is the same button for the Wireless tab. When my wireless hotspot is created, there is not settings access to it. The SSID is my computer domain ( me@my_domain ). – kaligne Jul 16 '14 at 10:26
0

Me and my friend had trouble setting up wireless hotspot manually. We used ap-hotspot which was much easier to set up. You can get it from:
http://www.webupd8.org/2013/06/how-to-set-up-wireless-hotspot-access.html

  • I installed ap-hotspot on my laptop but when I launch it with sudo ap-hotspot start it says Your wireless card or driver does not support Access Point mode. – kaligne Jul 16 '14 at 10:33
  • This will answer all of your questions then: askubuntu.com/questions/180733/… your wireless card probablly doesn't support ap – mmm3743 Jul 16 '14 at 11:49
  • 1
    I read it but I don't quite understand the concept of Access Point there. I mean if my wireless doesn't support it, them how could I create a wireless hotspot and connect to it? Because I really did create one and my other devices could detect my laptop! The only problem here is that I cannot edit my hostname and security key.. I don't understand – kaligne Jul 16 '14 at 15:06
0

Looking at the instruction from HERE

the explonation could be: "Unfortunately, there are some limitations. Some devices may not support ad-hoc wireless networks and Ubuntu can only create wireless hotspots with weak WEP encryption, not strong WPA encryption."

Cheers

0

I guess that you are using ubuntu-gnome.

You can change your Network Name,security key in /etc/NetworkManager/system-connections/Hotspot.

Here is what I did:

sudo vim /etc/NetworkManager/system-connections/Hotspot

//find options you want to change

//change it(you should be clear about the option you changed

:w!(force to save in vim command line)

:q(quit the config file)

restart the hotspot and you can see the change you did in System settings > Network > Wireless

0

I was trying to do the exact same thing as you (change my host name/security key for my hotspot) as there is no wifi in my home. Although you can't change the pre existing hotspot network information you can make a new one with your own info and a custom password (or no password). I'll be as detailed as possible for less experienced users reading this but it's rather simple and doesn't require a terminal (Only proven in 14.04 LTS

  1. From the desktop, click the power/settings icon in the top right corner and in the drop down click system settings. From there, click the network icon to bring you to your network settings. Here, you should see at least your wireless and wired connections available on the left hand side.

  2. Click your wired connection and turn it on (if not already). Now go to your wireless tab and also click that one on (if not already).

When you click into the wireless networks tab, you'll also see your wireless networks that are available. Basically, we are going to make a new entry to this list and use it as your hotspot.

  1. Exit out of the network window and go back up to the upper right hand corner of the desktop and, this time, click the Internet connection icon. In the drop down, click the "Create new Wi-Fi Network" option.

  2. A window will pop up where you can input your own info for the connection and your security preferences. For the connection type click hotspot and enter your desired info (if you don't want a Password, just click "none" under wifi security and leave the password area blank). Once finished, click create.

  3. Now if you go back to your network connections, you'll see your wireless connection is the one you just created, is active, and is transmitting as a hotspot. Now on your other devices you should see your custom connection appear. Also, You no longer have to click the "Use as Hotspot" button because this network is an internal one and is by default a hotspot.

I can verify that this worked at least for me because I wrote this on my iPod touch (hence the many edits) using the custom network I created. Hope this is what you were looking for!

**Troubleshooting ;) **

IF, for any reason you ever disconnect from your custom hotspot, just go back to the internet connections drop down in the upper right hand side of your desktop and, under wifi networks, it should be there for you to click and reconnect (it was created as a hotspot so that's all it can do). IF at any point the hotspot disappears from your wireless list, go to the same drop down and make sure both" networking" and "enable Wi-Fi" are enabled. Then go to "Edit Connections" to see if your custom network is on the list. If it is, it should still be there in the network settings window for you to click. If it is not, it was somehow deleted and you need to make a new one. However, upon repeating steps to create a hotspot, under "connection type", your info from your original hotspot should still be there under the same name. If not, simply re type and re create the hotspot.

-1

I just had same problem, I'm using Ubuntu 14.04 Gnome. Here is a alternative solution. Probably your OS has default Hotspot defined wireless. You can change its configuration manually from /etc/NetworkManager/system-connections. You can find tutorials for manually settings easily on the web.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.