7

I've just upgraded to 14.04 and installed the Gnome Flashback Session. However, Alt + Tab doesn't bring up an application switcher. I've tried Compiz Config Settings Manager, but there are no options for the switcher outside of the Unity menus. Is there a work around for this? I much prefer Classic / Flashback over Unity...

Any help is greatly appreciated...

22

First try through the

  • Basic settings

Go to 'Applications','System Tools','System Settings'

Click 'Keyboard'

Click the 'Shortcuts Tab'

Click 'Navigation' on the left

In the right-hand pane click on 'Switch applications' and press Alt-Tab to assign that as the accelerator.

EDIT: It's been marked in comments, citing "The first method alone does not work. The compiz plugins are definitely necessary!". I can not check it at the moment, now I just put this comment here.

Or can be fixed by installing

  • Compiz

and enabling Static Application Switcher

sudo apt-get install compiz
sudo apt-get install compizconfig-settings-manager

you might need to install compiz-plugins-extra as well and then

ccsm

enter image description here

9
  • @NoTime you will not need to run ccsm as a root, works without sudo. Jul 16 '14 at 2:02
  • When I try to install compiz-plugins-extras, I get this output: "Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: compiz-plugins-extra : Depends: compiz-plugins but it is not going to be installed" Any ideas?
    – Kyle Rebar
    Jul 16 '14 at 2:21
  • As it says you need have compiz-plugins installed. I will add it to the answer after your feedback with success. So, now sudo apt-get install compiz-plugins and then try again for extra. And if it is going to be mess again, try via Synaptic it easier resolve all dependencies (sudo apt-get install synaptic and the sudo synaptic and put compiz in search) Jul 16 '14 at 2:34
  • I wasn't able to install compiz-plugins or compiz-plugins-extras through terminal or synaptic. Same output. However, I tried purging and reinstalling the flashback session, now Alt+Tab switches as it should. I still can't install compiz-plugins or extras, but it works. I don't understand why, or what happened, but, I guess this is solved? Thanks, Ruslan!
    – Kyle Rebar
    Jul 16 '14 at 2:49
  • compiz-plugins-extra did the trick!
    – zpon
    Nov 26 '14 at 8:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.