2

I have an Asus Xonar U7 usb sound card and it works except for the microphone input which isn't recognized at all by pulseaudio. The "Input" tab in the sound settings is completely empty. I've tried using pavucontrol but the U7 is only listed there as an output, not an input.

It works on Windows and I'm having this problem on two separate computers (running Ubuntu 14.04 and Linux Mint 17).

The device is listed by arecord -l:

card 2: U7 [Xonar U7], device 1: USB Audio [USB Audio #1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

If anyone else is using the Xonar U7 then it would be great if you can confirm that it's working (or not) with audio input.

The farthest I've come is to get Audacity to record something (although very very low) by setting default audio device to Alsa in gstreamer-properties. Since my main use is Skype (which uses pulseaudio) this doesn't help very much.

alsamixer looks like this:

alsamixer

  • please open a terminal, issue the command alsamixer take a screen shot, upload it to imgur.com and provide us with the link. This will help us help you! – Elder Geek Jul 15 '14 at 18:40
  • Sure :) i.imgur.com/l2T4BTl.png?1 – skiplist Jul 15 '14 at 18:50
  • What happens if you unmute S/PDIF In? – Elder Geek Jul 15 '14 at 18:59
  • Nothing really :/ I tried unmuting and restarting but it's just the same. And it's listed as a Playback which makes sense because the only S/PDIF on the card is an output. The only ones listed on the "Capture" tab in alsamixer is PCM and PCM 1. I've no idea what is normal in this case – skiplist Jul 15 '14 at 19:19
  • Hopefully someone who has your device and can test will chime in. – Elder Geek Jul 15 '14 at 19:20
1

I fixed this on my U7 with the info in this post.

https://forums.gentoo.org/viewtopic-t-1025106-start-0.html


For posterity in case the form post disappears...

I found my answer here:

https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Microphone_not_detected_by_PulseAudio

The summary:

I edited /etc/pulse/default.pa to add the line:

load-module module-alsa-source device=hw:2,1

...since "arecord -l" showed that my missing mic was Card 2, Device 1

This newly-added line has to precede the lines:

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect

...in my case, this wound up being Line 52 of default.pa

I hope this can help someone else!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.