0

My Specification

  • Ubuntu 12.04 32 bit
  • Kernel 3.2.0-23-generic-pae
  • VGA Intel 2nd Generation Core Processor Family Integrated Graphics Controller
  • X.org 1.11.3
  • My /etc/X11/xorg.conf content:

Section "Device" Identifier "Configured Video Device" Driver "fbdev" Option "HWCursor" "off"

EndSection

Section "Monitor"
        Identifier      "Configured Monitor"
EndSection

Section "Screen"
        Identifier      "Default Screen"
        Monitor         "Configured Monitor"
        Device          "Configured Video Device"
EndSection

The Problems

Disappearing history:

Just some days ago. It happened to my Chromium 25 and same now at Chromium 34. I have never experienced this since my Ubuntu 12.04 first install in 2012.

Disappearing conditions:

  • When I hover my cursor on any element that has tooltip.
  • When I scroll in any application that has scrollbar.
  • When I click.
  • When I right click.
  • Cursor appears again if I move mouse a little bit.

Disappearing position:

  • In all desktop I have (KDE, Unity, Openbox).
  • In all GUI applications, Chromium it self and beyond.
  • In Konsole too.

Problem after starting Chromium:

directly my cursor disappears with conditions mentioned above.

Problem after starting Rekonq, Firefox, Konqueror, and Midori:

not directly, but in various duration (less than 1 hour), the cursor will disappear again with conditions mentioned above.

No Problems

  • It doesn't happen at all if I don't start any browser.
  • At reboot, my cursor always be normal again.

My Attempts

  • I have searched many askubuntu threads about cursor disappear, tried many things, but no luck at all.
  • I have no unclutter in my system.
  • I have removed nagios, mrtg, courier-*, mailman, postfix, squid3, apache2, nfs-*, bind9, and some packages I installed few days before this problem happened.
  • I have set "off" in HWCursor line in xorg.conf.
  • I have tried to disable all plugins (including Adobe Flash) on Chromium but the problems didn't change at all.
  • I have tried to delete .config/chromium/ folder on Home but the problem is still occured.
  • I have tried too gsettings set org.gnome.settings-daemon.plugins.cursor active false, but same.
  • I have read standard output via tailf /var/log/syslog when Chromium starts, but I didn't find any strange output.
  • I have asked a guy in #freedesktop but he said something like "it is strange, i couldn't help".
  • I have created new user on Ubuntu, login there, and the problem still occured. So I think it is not an usual configuration error.
  • I didn't do any kernelish thing before this problem happened.
  • I never do an upgrade before this problem happened (and actually my system is OK even with no upgrade at all). No kernel upgrade, no partial upgrade, even no package upgrade.

My Questions

  • What is the real problem for me? X Server (I thought it is not)? Webkit Engine (but it is too strange an engine affects a system)? Or what?
  • Any idea to solve this?
0

Problem

The real problem was apparently same with my new posted problem, Unity 3D Suddenly Disabled Ubuntu 12.04. The driver in my Ubuntu has switched to wrong driver. I don't have idea why and how.

Solution

Just revert the correct driver back.

Walkthrough

http://ubuntuforums.org/showthread.php?t=2234888

Conclusion

This problem was solved.

Not the answer you're looking for? Browse other questions tagged or ask your own question.