1

I have a HTC One m8, and when I plug it in it shows up in Files as "Android Phone". It shows my internal storage automatically, and at the top it says "Contains digital photos Shotwell". But the issue is, when I try to move a file from my phone's internal storage to a place on my computer (drag and dropping), I get an error and it doesn't work. It says there was an error copying it to file into /home/user/... And if I press show more details it says this: Error getting file: -6: Not Supported. Any help would be greatly appreciated, and I have seen others having this problem but no solution.

1

1) Close Shotwell

2) Open Nautilus

l1

3) Select your source device from the left column

4) click File, then New Tab

5) Select your target directory from the left column

6) Go to the original tab. Select all the files you wish to move. right click on one of the highlighted files and choose cut.

7) Go to the target tab. Right click in an empty space in the folder and choose paste.

5
  • 1
    Still got the same error. I tried running nautilus as root, but my android's storage wasn't listed there, so the only way I could access it was from Shotwell. What's weird is I can delete files off my phone in shotwell, and put files from my computer on my phone, but I can't do the opposite. – user305831 Jul 15 '14 at 21:17
  • Check the permissions on your target folder and insure that you are allowed to write to it. – Elder Geek Jul 15 '14 at 21:23
  • 1
    Yea I can write to it. It's also worth mentioning that I get the error, but it does create the file - with nothing in it. I tried moving over something that was 10mb and the same file name popped in my target folder, but I got the error and the file that was created was 0 bytes. – user305831 Jul 15 '14 at 21:31
  • @Zordid There's no need to be rude. That wasn't clear at the time I answered the question (at least to me). You might note that the best answers rise to the top here and you can downvote an answer if you feel it's not useful. – Elder Geek Dec 9 '14 at 14:43
  • It it Android 5.1 by chance? – NoBugs May 16 '16 at 5:37
1

I installed gmtp (sudo apt-get install gmtp), connected my phone, switched it to PTP not MTP. Opened gmtp, connected device through there, and it worked.

1
  • where did you switch from MTP to PTP? Can't find this on the One Max... – Zordid Dec 9 '14 at 14:41
-1

on the phone, go to settings>storage and then open the menu and select "usb commputer connection".set it to mtp, and try it and then see if setting it to ptp does anything. It seems like it is set to the original ptp type method, but not the compatibility version.

6
  • Didn't work, though thanks for the suggestion. When I do this, it opens up in shotwell, though it's all my pictures. Dragging and dropping works, but I'm trying to get other files to my computer's storage (not pictures). – user305831 Jul 15 '14 at 21:14
  • try installing dolphin and then just open the directory for the phone and copy the files that way, shotwell literally never worked for me – sbergeron Jul 15 '14 at 21:47
  • Probably something on my end, but I don't see my device listed on dolphin. – user305831 Jul 15 '14 at 23:02
  • is it set to mtp? Also, is the cable an oem? In the past I've found that a lot of aftermarket cables do NOT work for any kind of large scale data transfer – sbergeron Jul 16 '14 at 1:14
  • Yeah it's mtp. The cable is from LG, though I am using an HTC phone. I don't think that's the issue though, as transfering files from my computer to the phone works, but the opposite doesn't. – user305831 Jul 16 '14 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.