When I start my laptop, it takes as much as 7 tries to get past the place where the swap gets mounted. If anyone is looking over my shoulder then it becomes 15 tries! My laptop is a Lenovo W520 with an NVIDIA Quadro 1000M graphics card using the open source driver (X.Org X server) and Ubuntu 14.04. It is a triple boot, but I don't think this has any effect on this problem. I had this problem from the moment I installed 14.04,I was hoping some update would fix it, but it has been months and none of the updates have fixed it.

I found only one thread that is related to my problem, and have tried every offered solution in the entire wiki. None of them worked for me. The thread: My computer boots to a black screen, what options do I have to fix it?

My Symptoms:

  1. The last line on the screen when computer hangs is always: 'Adding 4215004k swap on /dev/sda6. Priority:-1 extents:1 across:4215004k FS'

    enter image description here

  2. The hard drive led on the laptop turns off

  3. The CPU fan goes into super high cool mode.

  4. computer will sit in that state forever (once i let it do that for over an hour)

Attempts to fix:

1) I followed the wiki mentioned above and tried 'no splash' and 'nomodeset' in the grub menu. I also played around by making the 'ro' in that same line 'rw' - hoping that additional permissions will help. As well, I plugged and unplugged my second monitor, the power supply and USB devices to see if any one item has a repeatable effect on my problem. It did not. I was hoping to find the culprit causing the problem, but all I found is that everything I tried had no direct impact on the problem. I kept a chart: track of various attempts

2) Two things we can rule out are (a) the screen is too dark - not the case (b)USB device causing this problem - not possible as problem persists with and without USB devices connected.

3) I made sure that in BIOS my 'Optimus' is disabled. As well I am using the open source driver, so I hope this is not an 'NVIDIA' problem, but a grub problem. BIOS Settings

4) I reinstalled the GRUB and that didn't help.

5) I played with /etc/defaults/grub but none of the suggestions I found on this website had any positive effect on my problem. The contents of my file is below:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#_MO_ I commented out the line below to see the shutdown process
#_MO_ the top line fixed my shutdown problems but I have startup 
# prolems now. So below I hope this works:

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

I am fresh out of ideas. If I may provide any information, or logs or perform some changes on my side please let me know.

Thanks in advance.


Edit #1********

I saw this post, does it apply to my problem? First Boot Not Happening [ 7.471657] Adding 4041724k swap on /dev/sda7 Priority :-1 extents: 1 across :4041724k FS

Here is my setup in GParted: enter image description here

Edit #2************ Several people suggested that I remove my swap partition. I did. However that only changed the problem; the booting got stuck on a different line. Basically instead of hanging up on the swap partition mounting, the boot hung up on my touch pad. When that happened the HDD LED turned off and the PC just sat there for several minutes before I had to restart it. After 3 back to back getting stuck in the same place I put the swap partition back. I took a picture of where it was getting stuck when the swap was gone:

enter image description here

Edit #3************

I made a mistake in the procedure I carried out in 'Edit#2'. After deleting the partition I never removed a line of code from /etc/fstub. so I repeated the process where I deleted the swap section, then I commented out the swap line in the /etc/fstub file. This did not fix my problem, but it did create different symptoms. This post is very long already so instead of including a chart I will simply provide the conclusions of rebooting my PC a total of 45 times without a swap partition.

  • it booted OK 25 times

  • it failed to boot 20 times

  • it is way, way, way more likely to boot up if the power is plugged in, the second monitor is plugged in, and my usb hub is plugged in (with no devices plugged into hub)

  • it is highly unlikely to boot up if nothing is connected to the laptop (no power cord, no vga cord for second monitor, and no USB hub). out of 20 failed boots 12 times there was nothing connected to the laptop.

  • when the PC fails to boot it is the same screen as in edit #2, even though I have seen a different screen as well when it freezes.

  • The state the PC is in messes me up, because when I take my laptop to the field, I need to have my laptop work, and since there are no cords connected to my PC it is not likely to start.

  • FYI: my /etc/default/grub is the same as in the body of the post. I set it as the first linked post suggested and kept it there as it has worked in the past for others.

  • For the sake of full disclosure there is another bug I thought to be unrelated, but since I made it this far, I want to get it off my chest: any time I try to adjust my screen brightness using a FN key and two brightness keys (HOME & END), the operating system freezes and does not unfreeze; requiring a PC restart by pressing the power button. This feature used to work in 12.04.

*********Edit #4

Here is what I did:

  1. sudo apt-get update

  2. sudo update-grub

  3. sudo shutdown now //this made my computer act really funny. It didn't quite shutdown correctly and I was looking at a screen with some 'Nouveau' message. I pressed the power button for 4 seconds and the computer shutdown. Here is what I saw:

    enter image description here

  4. Once the computer was shutdown, I unplugged all the cords (power, VGA, USB hub with no devices connected to it) and restarted the PC. It failed to boot, so I kept pressing the power button and restarting it until it finally booted (took about 3 tries to get it to boot).

  5. When the PC finally booted it asked for permission to report a problem to Ubuntu. I did report the problem.

  6. I got the contents of the following logs:

I am off to work, when I get back I will post the results of all the other suggestions (memtest, etc..). Thanks for all your help. Keep telling me what to do and I will do it and make a write up on the results here.

The info below is complemetary to oldfred's answer*

It seems that a solution has been found. 'oldfred' is the first to suggest a working solution. Thanks! I did a bunch of testing and ultimately this is what you need to do if you have this happen to you:

  1. Using GParted I added back my swap partition. the swap partition is not related to this problem. As several people noted, the swap message was just the last line displayed on the screen when the OS froze.

  2. To test if this solution works for you, when the purple grub screen appears press e to edit the entry. then add the following to the end of the line starting with Linux:

acpi_osi=Linux acpi_backlight=vendor final grub entery

  1. If this works for you, then to make this change permenant open your /etc/default/grub as sudo (sudo gedit /etc/default/grub)

  2. change the string of



GRUB_CMDLINE_LINUX="no splash acpi_osi=Linux acpi_backlight=vendor"

  1. lastly get GRUB to load you new settings by typing

sudo update-grub

  • Please do not post solutions on the question. That is what answers are for.
    – Lucio
    Aug 2, 2014 at 20:40
  • This is a bug and should be reported on Launchpad.
    – bain
    Aug 3, 2014 at 13:12

1 Answer 1


I believe it still is a video issue.

And boot parameter for grub is nomodeset with nVidia, but different parameters if booting with Intel. Can you set which video chip you boot with?

See this

After using Boot-Repair I cannot change screen resolution

You test alternative boot parameters at grub menu using e and scroll to linux line. Replace quiet splash or add after those boot parmeter those settings you want to test. Once you get a combination that works edit /etc/default/grub

But you may also need acpi_osi=Linux and/or acpi_osi=Linux acpi_backlight=vendor

gksudo gedit /etc/default/grub
sudo update-grub

So on this line add boot parameters that work.

GRUB_CMD_LINUX_DEFAULT="no splash acpi_osi=Linux acpi_backlight=vendor"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .