2

On a recent update to my precise install the package manager seems to have got itself into a twist.

cat /var/log/apt/history.log

Start-Date: 2014-07-10  16:17:22
Upgrade: libdbus-1-3:amd64 (1.4.18-1ubuntu1.4, 1.4.18-1ubuntu1.5), libdbus-1-3:i386              (1.4.18-1ubuntu1.4, 1.4.18-1ubuntu1.5), dbus:amd64 (1.4.18-1ubuntu1.4, 1.4.18-1ubuntu1.5),   flashplugin-installer:amd64 (11.2.202.378ubuntu0.12.04.1, 11.2.202.394ubuntu0.12.04.1), dbus-x11:amd64 (1.4.18-1ubuntu1.4, 1.4.18-1ubuntu1.5)
Error: Sub-process /usr/bin/dpkg returned an error code (2)
End-Date: 2014-07-10  16:17:41

Output from apt-get update

You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
libdbus-1-3 : Breaks: libdbus-1-3:i386 (!= 1.4.18-1ubuntu1.4) but 1.4.18-1ubuntu1.5   is installed
libdbus-1-3:i386 : Breaks: libdbus-1-3 (!= 1.4.18-1ubuntu1.5) but 1.4.18-1ubuntu1.4   is installed
E: Unmet dependencies. Try using -f.

apt-get -f install

dpkg: error processing libdbus-1-3 (--configure):
libdbus-1-3:amd64 1.4.18-1ubuntu1.4 cannot be configured because libdbus-1-3:i386 is   in a different version (1.4.18-1ubuntu1.5)
dpkg: error processing libdbus-1-3:i386 (--configure):
libdbus-1-3:i386 1.4.18-1ubuntu1.5 cannot be configured because libdbus-1-3:amd64 is   in a different version (1.4.18-1ubuntu1.4)
Errors were encountered while processing: libdbus-1-3 libdbus-1-3:i386
E: Sub-process /usr/bin/dpkg returned an error code (1)

I guess the i386 version no longer matches the x86_64 version for some reason? I'm unclear how to resolve this. Help appreciated. Many thanks in advance

1

Run sudo dpkg --remove libdbus-1-3:i386. dpkg will likely complain about unmet dependencies. Then, run sudo apt-get install libdbus-1-3 libdbus-1-3:i386 to upgrade the amd64 package (if needed) and install the i386 package.

  • It does indeed complain and refuses to proceed. dpkg: dependency problems prevent removal of libdbus-1-3:i386: libavahi-client3:i386 depends on libdbus-1-3 (>= 1.1.1). gvfs:i386 depends on libdbus-1-3 (>= 1.0.2). gvfs-libs:i386 depends on libdbus-1-3 (>= 1.1.1). libpulse0:i386 depends on libdbus-1-3 (>= 1.1.1). libqt4-dbus:i386 depends on libdbus-1-3 (>= 1.3.1). Should I use --force? – Thin Jul 15 '14 at 16:04
  • @Thin: Yes. I wasn't sure if it would block the removal or not. – saiarcot895 Jul 15 '14 at 16:05
  • thanks sudo dpkg --remove --force-depends libdbus-1-3:i386 worked to remove it. However on running the install command you provided it returns 'dpkg: error processing libdbus-1-3 (--configure): libdbus-1-3:amd64 1.4.18-1ubuntu1.4 cannot be configured because libdbus-1-3:i386 is in a different version (1.4.18-1ubuntu1.5) dpkg: error processing libdbus-1-3:i386 (--configure): libdbus-1-3:i386 1.4.18-1ubuntu1.5 cannot be configured because libdbus-1-3:amd64 is in a different version (1.4.18-1ubuntu1.4)` – Thin Jul 15 '14 at 17:42
  • 1
    Can you run sudo dpkg --remove --force-depends libdbus-1-3 to remove the amd64 version as well, and then run sudo apt-get install -f? – saiarcot895 Jul 15 '14 at 19:41
  • Thanks, that seems to have resolved it now. Am I being thick to not understand why it broke in the first place / couldn't resolve that itself? – Thin Jul 15 '14 at 21:26
0

Based on this answer, the following instructions helped me to solve similar problem:

dpkg --add-architecture i386
apt-get update
apt-get install libdbus-1-3:i386
apt-get -f install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.