4

Running Nautilus 3.10.1 on a DE-less install of Ubuntu 14.04. Running Nautilus as my regular user account, I can't even set the "show folders before files" option in Preferences - as soon as I toggle the checkbox, the checkmark disappears again. Running Nautilus as root, I can toggle the checkbox just fine but it's toggled back off when I switch between list and grid view. What's the deal with that, and how do I make that option stay enabled?

  • What do you mean by "DE-less"? I'm betting that is part of the trouble. – Seth Jul 15 '14 at 4:28
  • what is DE-less ?? – Rahul V Sharma Jul 15 '14 at 4:41
  • Presumably OP installed components manually instead of using something like ubuntu-desktop. – muru Jul 15 '14 at 4:43
  • DE is for desktop environment. I kind of got disgusted with GUIs and built a minimal system from a 30MB Trusty mini.iso. I'ma startin' ma X with startx into a very light tiling window manager (xmonad). nautilus has always been a sport, very convenient when you need a quick graphical file manager, but I didn't expect it'd depend on Gnome's infrastructure to remember its own settings. What do I need to do to make it behave? – avramov Jul 15 '14 at 9:28
12

This worked for me on Ubuntu 16.04:

dconf write /org/gnome/nautilus/preferences/sort-directories-first true
| improve this answer | |
3

Looking at the terminal output for gedit (which also showed similar behavior), I noticed this error:

(gedit:12801): dconf-WARNING **: failed to commit changes to dconf: 
GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._g_2dfile_2derror_2dquark.Code2:
Failed to create file '/home/username/.config/dconf/user.FV01IX': Permission denied

Turns out ~/.config/dconf was owned by root. Chowned it back to username:username and everything's fixed now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.