3

I've recently change my PC OS from MS to Ubuntu.

Ubuntu 14.04 can correctly find my HDMI audio but with terrible echo and crackling sound.

I fix the echo issue by following the guide here: Sound problems in Ubuntu 14.04, and Static and crackling in my HDMI audio?. But the crackling sound still exist. I tried updating the video card driver directly from AMD website, didn't help either.

I also try to change the default sampling frequency in /etc/pulse/daemon.conf to 44100 or 48000, both won't work.

I'm using video card MSI ATI R7 260x. How can I fix it, thanks!

5

This one helped me: [Static and crackling in my HDMI audio?]: Static and crackling in my HDMI audio?

edit

/etc/pulse/default.pa

look for

load-module module-udev-detect

add tsched=0

load-module module-udev-detect tsched=0

reboot

1

Found the solution here:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1321421

Cause my PC comes with an Intel Z97/H97 chipset, the solution to solve this problem is:

  1. sudo nano /etc/modprobe.d/alsa-base.conf

  2. Add options snd-hda-intel vid=8086 pid=8ca0 snoop=0 at the end of the file.

  3. Restart PC

  • Solved my radeon 290x hdmi audio noise/crackes on Ubuntu 14.04, thanks. – Le Gluon du Net Mar 1 '15 at 18:03
0

This was taken on Ubuntu website and solved it for me

HDMI Audio

The open-source radeon driver supports HDMI audio on Radeon HD 6000-series and earlier chips. On Trusty/14.04 and newer, HDMI audio should work automatically.

On release older than Trusty/14.04, users will need to to enable HDMI audio manually by passing the radeon.audio=1 kernel parameter. It can be done with the following command:

echo "options radeon audio=1" | sudo tee /etc/modprobe.d/radeon.conf

Ubuntu Precise/12.04 users should also note that they may need a newer kernel (>= 3.5.x) to enable HDMI audio on later cards

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.