0

I tried installing proprietary fglrx drivers by following instructions from https://help.ubuntu.com/community/BinaryDriverHowto/AMD However the installation failed with the error 'amdconfig: No supported adapters detected'.

Now laptop boots to a purple screen followed by the black screen. I had made a backup of the xorg.conf file but replacing it does not solve the problem.

I am lost. Please help me get the login screen back.

UPDATE

As suggested I tried adding nomodeset after "quiet splash" in the Grub-menu. However the system still boots to a black screen. Here are the current grub settings:

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=0

GRUB_HIDDEN_TIMEOUT_QUIET=TRUE

GRUB_TIMEOUT=10

GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'

GRUB_CMDLINE_LINUX_DEFAULT="radeon.modeset=0 vesafb.nonsense=1 quiet splash nomodeset"

GRUB_CMDLINE_LINUX=""

Kindly suggest what else can be done to rectify the problem.

  • A typical solution I've seen for these kinds of problems is to add nomodeset to the end of GRUB_LINUX_CMDLINE_DEFAULT in /etc/default/grub and then run sudo update-grub. However, some people have noted that this decreases graphics performance (low resolution, less sharp image). – hal7df Jul 15 '14 at 4:03
0

I think that you have to edit grub. For that, ESC at the beginning of the boot. After: e (to edit). At the end of the line which start by "Linux...", add nomodeset after "quiet splash". Then F10. Normally, you be be able to boot. If you want to keep nomodeset for the next boot, you need is to "add nomodeset to the end of GRUB_LINUX_CMDLINE_DEFAULT in /etc/default/grub and then run sudo update-grub", as hal7df explained to you.

But maybe the best idea is to desinstall fglrx. I have also a AMD HD8670M in hybrid video card, on Ubuntu 14.04, without fglrx. I do not think that AMD HD8670M is used, because lspci -nn | grep VGA gives me 00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

But my computer works well. I change the brightness, which I could not do before with others Ubuntu versions; suspend an resume. The only problem is that the fan sometime is noisier than on Windows 8.1

0

I did this on my 15" MBP 2011 with a failed dGPU after a failed NVRAM reset rendered my initial hack useless to boot into MAc OS, and the screen boots into black after grub.

If you have an Ubuntu USB installer/booter (mine's 18.4.20), boot into it, and when grub appears, type 'e' and edit the grub menu.

menuentry "Try Ubuntu without installing" {
   set gfxpayload=keep
   outb 0x728 1
   outb 0x710 2
   outb 0x740 2
   outb 0x750 0
   linux   /casper/vmlinuz  file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0 ---
   initrd   /casper/initrd
}

In this case, you can skip adding [nomodeset], the computer should boot into iGPU with a clean, undistorted screen, since [nomodeset] lets me boot into a green colored screen.

Do either of the two.

1) Install Ubuntu if your starting over, don't worry about partitioning and let Ubuntu erase everything (since you are using a blank drive) and do not include 3rd party drivers.

Reboot into the USB, and enter the same codes previously.

2) Assuming you're just going to edit the installed grub (and you haven't edited it before), reboot (pressing alt to boot into the USB). When the GUI comes up, open Files app> Other Locations >Computer> Boot> Grub, and look for the grub.cfg file.

Open a Terminal and type:

sudo chmod 777

Then drag the grub.cfg file into the terminal window. Press enter. This changes the file's permission to R/W.

Open the grub.cfg file, and look for the [menuentry 'ubuntu'] line. Below this is the [load_video] line. After this line, add

   outb 0x728 1
   outb 0x710 2
   outb 0x740 2
   outb 0x750 0

A few lines below that is the Linux kernel line. After 'quiet splash' add

 i915.lvds_channel_mode=2 i915.modeset=1 i915.lvds_use_ssc=0

Which should give you something like this

This allows you to edit the grub to turn of the dGPU and switch into the iGPU.

Save the file, and do this in Terminal:

sudo chmod 444

then drag the grub file into the terminal window. If you haven't closed terminal yet, just issue the last sudo chmod command by pressing the up key and change 777 to 444, and this changes the file's permissions back to read-only.

This assumes you didn't reboot to test if it works.

Reboot the computer. Ideally, if you did things right, it should boot directly into Ubuntu, bypassing the grub entry altogether. You can still access the grub menu by pressing option/alt.

In my case, I did add [nomodeset] after quiet splash without adding the [outb] operands the first time around since I was basically shooting in the dark, trying everything I can just to be able to boot up into a desktop to install Ubuntu. The key (at least in this case) is editing the grub.cfg file of your install to include the outb and i915.lvds operands.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.