6

I did a clean install of Ubuntu 14.04, along dual booting Windows 7.

I love Ubuntu but then suddenly the power went out and the next thing I know my battery ran out of juice in less than 30 minutes.

Usually my battery lasts for 3 hours with Windows 7, but on Ubuntu its considerably less please give me some advice.

  • Did you have the laptop plugged into the charger when the power went out? – ryekayo Jul 14 '14 at 16:26
  • yeah sure I had it plugged in – warmachinerockxxx Jul 18 '14 at 13:57
  • You probably shorted out the battery. – ryekayo Jul 18 '14 at 14:26
7

Optimize your screen brightness, so it consumes less power.

Or you should also monitor your system activities by ctrl + tab and see if any process consuming lots of CPU and resources, Consuming more CPU results more heat up and less power.

Or you can install PowerTop to see what's taking the power so you can optimise your system.

To install: sudo apt-get install powertop

| improve this answer | |
  • sorry to tell you man but I've already tried doing that :( – warmachinerockxxx Jul 14 '14 at 16:29
  • install powertop tool or you should see it ezinearticles.com/… – Rahul V Sharma Jul 14 '14 at 16:35
  • could you please elaborate>>>??? – warmachinerockxxx Jul 14 '14 at 16:35
  • 1
    Powertop is a command line tool which will show you which process consuming more power. sudo apt-get install powertop To run it sudo powertop – Rahul V Sharma Jul 14 '14 at 16:38
  • 1
    @Sharmarahul I've edited your question to include the answer which you had not given in the answer but as a comment. – Warren Hill Jul 14 '14 at 18:50
4

For me tlp has worked best. Try installing it as described here. You will have to purge laptop-mode-tools package if it is installed on your system else tlp will refuse to start.

| improve this answer | |
0

If your computer is also overheating and with the fan constantly on, it could be something to do with your graphics card and their drivers.

But for an adequate answer find out what graphics card your have (you can find out by running lspci in the terminal).

| improve this answer | |
  • Could you elaborate what tweaks you did to fglrx to conserve power? Thanks. – user68186 Jul 16 '14 at 19:37
  • 2
    Welcome to Ask Ubuntu! You may wish to improve/expand on your answer. Or if you cannot you may wish to move this to a comment. – No Time Jul 16 '14 at 19:49
  • Actually, to fix my problem I had with my radeon card (in ubutnu 13.04) I added the following code to my rc.local to disable vgaswitcharoo: chown USER /sys/kernel/debug/vgaswitcheroo/switch echo OFF > /sys/kernel/debug/vgaswitcheroo/switch modprobe radeon – rubensoleao Jul 16 '14 at 20:25
0

Try to change the user interface. Unity is heavy enough, so you have lightweight user interface choices such as XFCE (lightweight), LXDE (more lightweight), or Openbox (very lightweight). Try to install one and relogin by choosing user interface you have installed in the display manager.

XFCE

enter image description here

LXDE

enter image description here

Openbox

http://restava.files.wordpress.com/2014/07/openbox-tint2-conky8.png

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.