I have already looked at the similar questions, but none of the solutions there worked for me. Basically, I can edit and remove icons just fine when I am in a session, but the next time I am logged in, they are reset to the default.

Even more perplexing is this. If I start dconf-editor, and navigate to desktop>unity>launcher, it shows the favorites that are supposed to be there, yet the default ones are still in the Launcher.

I have already tried sudo apt-get purge unity and then sudo apt-get install unity from a GNOME session, but to no avail. Any suggestions?

Edit: I also tried running gksudo dconf-editor to run the program with elevated privileges. Again I navigated to desktop>unity>launcher. This time the default string was there, but when I tried to edit it, it would not change to what I typed.

  • Do you use Natty? This is very weird, though. Try unity --reset.
    – fitojb
    Jun 21, 2011 at 4:47
  • I have tried unity --reset. However, when I do that, the command always seems to halt at a certain part. I'm not sure at what part though. I'll try running it and letting it sit for an extended period of time and then I'll try it with elevated privileges.
    – mpace965
    Jun 21, 2011 at 16:45
  • Did you try this one? askubuntu.com/questions/35625/… Jun 21, 2011 at 16:52
  • @Jorge Yes I have.
    – mpace965
    Jun 21, 2011 at 17:02
  • When I try sudo unity --reset, it doesn't like that. Here is the output: pastebin.com/mycrRQXt. When I just do unity --reset it gets to a certain point, then hangs. Here is the output for that: pastebin.com/sMjikhwb
    – mpace965
    Jun 21, 2011 at 17:27

3 Answers 3


Here again to notify that after the installation of dconf-tools, libdconf-dbus-1-0, libdconf0 everything goes well:

sudo apt-get install dconf-tools libdconf0 libdconf-dbus-1-0

I found this on a bug submitted for empathy that did not save the settings.

  • I've done this but still am having problems. During unity --reset I get this error message several times: GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.
    – matpie
    Sep 8, 2011 at 2:22
  • UPDATE: I had to uninstall and then install libdconf0 in order to get my panel to start saving icons.
    – matpie
    Sep 8, 2011 at 2:38

Do you also get the error message

GLib-GIO-Message: Using the 'memory' GSettings backend. Your settings will not be saved or shared with other applications.

when you do gsettings monitor com.canonical.Unity.Launcher favorites?

It would be a bug similar to https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/620733 then, and you could solve it by installing dconf, libdconf0, and libdconf-dbus-1-0 package

At least that’s what worked for me, when my launcher didn’t remember the favorites.

  • I installed those packages and restarted, but when I ran gsettings monitor com.canonical.Unity.Launcher favorites it showed the same error as before.
    – mpace965
    Jun 22, 2011 at 21:37

I had to do a step before reinstalling dconf-tools, libdconf0, libdconf-dbus-1-0, removing them completly with

sudo apt-get remove dconf-tools libdconf0 libdconf-dbus-1-0
  • Ok....everything was looking fine until I launched dconf. Result: it crashes with the following error ** ERROR **: dconf.vala:96: unknown command aborting... Sep 11, 2011 at 21:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .