0

I have the proxy address, a user name and a password for the proxy server I need to connect through, but when I set the proxy details under System Setting => Network => Network Proxy, only Firefox seems to be able to connected to the Internet.

The Ubuntu Software Centre and apt-get does not seem to be able to connect to the internet, I have already tried this and a bunch of other things but nothing seems to work.

2
  • you found the right direction. Just add the line Acquire::http::proxy "http://user_id:password@proxy_server:port/"; in the file /etc/apt/apt.conf. If the file does not exist create one. – sourav c. Jul 14 '14 at 12:49
  • next type in terminal sudo apt-get update. – sourav c. Jul 14 '14 at 12:53
0

Go to your system settings --> network, select network proxy and then manual. Here you can enter your proxy settings, and save them.

After that open up a terminal, open your bashrc file in ~/.bashrc and add the following line;

export {http,https,ftp}_proxy=http://**YOURUSERNAME**:**YOURPASSWORD**@**HOST**:**PORT**/
3
  • Thank you but doesn't work. – Jonny Jul 15 '14 at 5:50
  • @Michael_K, can you try the edited string i posted? And after that do a restart please? – radriaanse Jul 15 '14 at 12:03
  • Im at a different PC now but will give it a try thanks @remyseroos! – Jonny Jul 15 '14 at 14:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.