0

I'm using Xubuntu on a iMac. When I have a output device attached (whether that be headphones or speakers) it plays through both the built-in audio, along with the device and I'd like to prevent this from happening. I'm not very experienced with Linux, Ubuntu, or Xubuntu, so any feedback or additional information I can get would be helpful.

Edit (Information)

  • When running the command pavucontrol, and going to the "Output Devices" tab. The only connected device shown is "Built-in Audio Analog Stereo" (even when selecting "All devices")

enter image description here

0

I have been searching for a solution to this for over year and haven't found one yet. First, check if auto muting is enabled in alsamixer. If auto muting is enabled, then what I do is to mute a channel in ALSA mixer. The channel you have to mute you'll need to find by trial and error. Open a terminal and start the alsamixer program. Change cards if you think the channels are too few. The last few columns will contain one for the auto muting option, which can have various values. Toggle to see if any one is the effect you want. If none suit you, experiment with disabling channels until it's satisfactory. (Press 0 when a channel is highlighted to set volume to zero, or press m to mute).

  • Thank you, this really helped out. All the other related answers I saw did not have an answer like this. – user288187 Jul 14 '14 at 13:20
  • Wait... The problem hasn't been fixed. I've tried adjusting some things around... and there doesn't seem to be a way to turn my built in speakers off. – user288187 Jul 14 '14 at 13:24
  • When I turn the option "Speaker" all the way down to 0, but "headphones" all the way up it still plays out the built-in speakers. The only other way I've found to turn off the built-in is by turning "PCM" all the way down or "Master Volume", but these also turn down everything else. – user288187 Jul 14 '14 at 13:28
  • Nevermind, I've seemed to fix the issue. When I turned "Speaker" all the way down I think it was still playing because "Bass Speaker" was still on. But never the matter, I've fixed it with your help. – user288187 Jul 14 '14 at 13:33
  • I've found another issue. When I use the volume buttons it basically resets back to it's original state. The speakers go all the way back up, and headphones all the way down. Is it possible to change when I use the volume buttons it adjusts the headphones instead of the speakers. (Remember I'm planning on never using the built in speakers) – user288187 Jul 14 '14 at 13:37
0

setting auto-mute = 0 works for Toshiba Satellite A105 ( enables sound on the laptop speakers finally )

  • 4
    Welcome to Ask Ubuntu! I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Dec 14 '16 at 13:22
  • norm a little more information please. – George Udosen Dec 16 '16 at 8:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy