2

I have proxy set in in my office laptop for work at office. I am trying to connect to wireless at home but it is not letting me do this. I tried steps in the link below without any succes. http://www.ubuntugeek.com/how-to-configure-ubuntu-desktop-to-use-your-proxy-server.html

I am able to change the firefox setting and it is working perfect.

When doing apt-get through terminal it tries to go through proxy. I see that the echo $http_proxy still have the proxy address.

I tried following:

cat /etc/apt/apt.conf This file does not contain anything. gedit /etc/bash.bashrc has no mention of proxy.

I set the network proxy none, but nothing happened.

Wrote acquire::http:: proxy "false"; in /etc/apt/apt.conf, I get this acquire::http:: proxy "false";

What is wrong with my settings? Thanks

1

You most likely have http_proxy set either as a system-wide setting (either in /etc/profile or in /etc/bash.bashrc) or as your private setting (in ~/profile, ~/bashrc or wherever your sysadmin decided to put it).

You can get-rid of that per bash session using unset:

unset http_proxy
unset https_proxy

Or you disable it permanently when you locate where exactly it is being set.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.