0

I'm using Asus A450L: Here are some info:

cat /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-3.13.0-30-generic.efi.signed root=UUID=d1cccc17-9e70-4682-bb40-c3df0db22e36 ro quiet splash vt.handoff=7

lspci -k | grep -A3 VGA

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
Subsystem: ASUSTeK Computer Inc. Device 13fd
Kernel driver in use: i915
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)

for i in /sys/class/backlight/*; do echo $i; cat $i/brightness; cat $i/actual_brightness; cat $i/max_brightness; done

/sys/class/backlight/acpi_video0
100
100
100
/sys/class/backlight/acpi_video1
18
18
100
/sys/class/backlight/intel_backlight
103
103
937

I have tried these solutions and none works:

  1. Create a file in /usr/share/X11/xorg.conf.d/20-intel.conf

    Section "Device"
       Identifier  "card0"
       Driver      "intel"
       Option      "Backlight"  "intel_backlight"
       BusID       "PCI:0:2:0"
    EndSection
    
  2. GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" in /etc/default/grub

Thanks.

1

I can't seem to find a solution for this.

But i found a workaround that might include installing a package.

It's a brightness app inspired from original Gnome brightness applet. Here's more info: http://ubuntuguide.net/add-brightness-control-to-unity-panel

Installing

In terminal run these:

sudo add-apt-repository ppa:indicator-brightness/ppa
sudo apt-get update
sudo apt-get install indicator-brightness

If the indicator doesn't start on your top bar, you can initiate it from dashboard

Add Keyboard Shortcut

Since function key fn + [whatever up/down for brightness] is not working.

We have to make our own shortcut.

Go to: System Settings -> Keyboard -> Shortcuts Keyboard Shortcut Utilities

Here, to add use +

Brightness-Up command: /opt/extras.ubuntu.com/indicator-brightness/indicator-brightness-adjust --up

Brightness-Down command: /opt/extras.ubuntu.com/indicator-brightness/indicator-brightness-adjust --down

Click the "Disabled" to assign shortcut key

Done. Until the fix comes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.