5

I'm running Ubuntu 14.04LTS and I'm getting video tearing (top, bottom, mid, it's horrible) on videos (mplayer, Youtube, moving windows around...).

My graphics adaptor is an ATI AMD Radeon HD 6700M Series. It happens regardless of the driver I install.

Tried all the following drivers: Xorg default, ATI Proprietary, Catalyst 14.4 (didn't work at all) and Catalyst 14.6 Beta (using this one now).

I already tried MANY different fixes I found online during this week, but nothing seems to work.

Gaming, for instance, does not get affected as far as I can notice.

My CCC doesn't show the 'Anti Tear' option. I read somewhere that it's due to dual graphics card being present (Intel/ATI).

Does anybody have a clue how to fix this?

Thanks!!!

4

Reinstall the Graphc driver:

sudo apt-get --purge autoremove xserver-xorg-video-radeon && sudo apt-get install xserver-xorg-video-radeon

Then reboot.

  • Still having same problem. – Bononi Jul 13 '14 at 16:38
  • EDIT: The tearing has been reduced 99% by using the reinstalled Xorg driver when watching videos and moving windows around, however Youtube (window and fullscreen) remains with the same issue. Any other ideas? Thanks! – Bononi Jul 13 '14 at 16:50
  • Found the Solution! It turns out that on top of the Graphics update, I had to also change something on Chrome. Will add the answer as soon as StackExchange/AskUbuntu allows me to (in few hours :P) – Bononi Jul 13 '14 at 17:03
  • turning ON acceleration for hardwarde in Chrome I assume ;) – Kalamalka Kid Mar 19 '16 at 3:29
11

Found the solution as follows:

Go to chrome://flags

Look for “Override Software Rendering List”, i.e. enabling GPU acceleration on unsupported hardware and ENABLE it, RESTART chrome (close the background process if you have that running on the top of the bar)

http://www.webupd8.org/2014/01/enable-hardware-acceleration-in-chrome.html

  • Had same problem in Chrome. This solved it. Thanks. – NahsiN May 20 '15 at 18:56
2

@Mookey's solution worked for me, but I would like to expand on it a bit more.

I too had the same problem on Ubuntu 15.10 with the open source radeon drivers. Video playback caused severe tearing during high-motion scenes. One video caused lots of tearing in VLC but next to none in Totem.

The xorg options for radeon point at the solution:

XV_VSYNC ... If you are using a compositer, this does not prevent tearing because Xv is rendering to an offscreen buffer and the compositor copied it to the front buffer.

If you install CompizConfig, you can adjust Unity's Composite plugin—among a great many other things. Search for it in the filter dialog box. If you mouse-over the "Unredirect Fullscreen Windows" option, the tool-tip reads:

Allow drawing of fullscreen windows to not be directed to offscreen pixmaps.

Turning the option off (it defaults to on) will use the offscreen pixmaps, allowing the radeon driver to do its work. If this works, the effect will be nearly immediate. No need to close CCSM or reboot. Just restart VLC or the offending application and try it out. If it doesn't work, reset the option to default.

It is somewhat ironic that a feature introduced to prevent tearing actually causes it. But the feature was introduced to fix performance issues with the compositer. If you disable the option, you may have performance issues with full-screen games.

So instead of disabling it entirely, you might try editing the "Unredirect Match" option to remove the applications which are giving you trouble. Oddly, the entry for VLC is wrong. It is listed as Vlc, but xprop lists its class as vlc, all lower-case. Perhaps this is a bug. When I fix the spelling, but leave Unredirect on, VLC no longer tears.

Ultimately, we need a replacement for X, such as Wayland or Mir, which will finally make tearing a relic of the past. Tearing is a common issue on many linux installs, and it's very difficult to stamp out.

1

I had the same problem and actually, what helped me was the opposite of what people are stating.

INstall Compiz with plugins Under Composite UNCHECK detect frame rate + undirect fullscreen windows. Let me know if it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.