I am trying to install Ubuntu on a Lenovo G500, CPU is Intel Core i3-3110M, 4GB RAM, and as you can guess, dual graphics: Intel HD 4000 for the basic stuff and AMD Radeon HD 8570 for the good stuff.

I went through the installation without problems, but when I try to boot the system fails: initially I get a message that the screen, graphics adapter and keyboard/mouse could not be automatically configured.

I have tried installing fglrx through APT and from AMD's proprietary drivers. I then installed XFCE as well.

Through some testing, I have realized that whenever I try to use X11, it gets stuck with the aforementioned message. I can then go into the commandline and delete the xorg.conf files from /etc/X11. After this, I am able to arrive to the logon screen.

When I try to log in everything freezes up (with the Unity interface). I successfully pass through the authentication, but then nothing happens. Occasionally there are some popups saying that there have been system errors and prompting me to report them, but nothing else. If I try to use an XFCE session, it works just fine. Why can I not access Unity?

In XFCE, I tried to install the Catalyst Control Center in order to deactivate the AMD card as I need the battery life. However, as soon as the packages are installed, it reverts to the error message (GUI could not be configured, the system is running in low graphics mode, blah blah blah).

What I noted today is that by running the command lspci I see the Intel GPU as a VGA adapter, while the AMD device is listed as a Screen Adapter (no VGA). Perhaps it has something to do with this.

If anyone has any idea or hint, it would be most appreciated.

Another thing is that I did this to another laptop with switchable graphics, a Samsung with Intel HD 3000 and AMD Radeon HD 8750, and it works perfectly fine. As soon as I installed the proprietary drivers, I was able to execute CCC and set it up to use the Intel VGA only.


Have you tried removing the aticonfig?

sudo aticonfig --uninstall

If it persists...I had a similar problem last week and this worked for me:

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

sudo rm /etc/X11/xorg.conf

sudo apt-get install --reinstall xserver-xorg-core xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri libgl1-mesa-glx:i386 libgl1-mesa-dri:i386

sudo dpkg-reconfigure xserver-xorg

sudo shutdown -r now

I hope you can fix it... I know how annoying it is =/ Good Luck!

  • You, sir, deserve a medal! :D It did work, I am now inside the default Ubuntu desktop thanks to you, and the graphics cards are both identified correctly. I want to disable the AMD card from CCC, but when I try to execute it I get an error, and aticonfig --initial seems to break everything. You did answer my initial question though, and I am very grateful, thank you again! However, any thoughts on the secondary issue would be greatly appreciated... :) – Iordan Iordanov Jul 13 '14 at 17:34
  • Not really... I hope you can fix this new issue... If I come across any new info I'll update you. Good Luck! :) – Bononi Jul 13 '14 at 18:43
  • Excellent! I have the same problem! – Suspended Feb 25 '16 at 6:07

Head on to /usr/lib/fglrx in this folder there are 2 nice scripts switchlibGL and switchlibglx
If you want to switch to intel run like this

./switchlibglx intel
./switchlibGL intel

Now if we want to query which adapter is being used

./switchlibglx query
./switchlibGL query

In case you want to switch back to AMD try

./switchlibglx amd
./switchlibGL amd

It worked for me on my Dell Inspirion 15R laptop

  • What is the difference between glx and GL – rahulroy9202 Mar 30 '15 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.