1

I had taken the following steps with Ubuntu-12 and it had worked perfect. But on a new laptop, I installed Ubuntu-14 and I am not getting access to iTrans conformant typing or transliteration scheme for the Sanskrit language. Ubuntu-14 gives me access to Hindi language's Bolnagri and Wx schemes and Sanskrit language's KaGaPa Phonetic, but these schemes are new to me; and I know for fact that 15-20 years ago iTrans conformant typing was the norm and it was available with Ubuntu-12. So why this new change, which is perhaps not for the better? How can I add to Ubuntu-14 what was the default for Sanskrit Lang under Ubuntu-12?

System Settings > Language Support > Install/Remove Languages

I added Sanskrit and Hindi at the step above.

Then I checked under : Text Entry Settings > Input Sources To Use > AND I only see options like KaGaPa Phonetic, Bolnagari et al. I would like my ubuntu-12 setting back. I do not remember the technical name for that transliteration scheme for Sanskrit Lang typing support to Dev-nagari script.

Please advise. I hope this is the correct place where to ask for this help.

1

Install the ibus-m17n package and relogin. Then you should see a Sanskrit (IAST (m17n)) option in the list of input sources. Probably that's what you want.

  • I tried ibus-m17n. And it worked for me. – The Dentist Jul 13 '14 at 9:51
  • Thanks for answering. I installed ibus-m17n package, and its 'Harvard-Kyoto m17n' option does help me a lot. But it is still not as good as iTrans conformant scheme. Gmail's Sanskritam-Phonetic scheme comes very close to being fully iTrans conformant. But I would like to be able to type in Devnagari script direct in any edit-box. I am way better off than where I was yesterday, but still not quite there. I will search some more to be able to do iTrans conformant typing. (To muru - I am not using this on a mobile.) – user137392 Jul 14 '14 at 7:44
  • Did you find your way? I have been using inscript as entry method, and it is the standard layout available. System Settings > Text Entry > Input Sources And add there "Indian". It is stupid name, but when selecting indian, devanagari (Inscript) is the default keyboard layout. – Ossi Viljakainen Oct 7 '15 at 12:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.