0

My Ubuntu machine was working all right since a long time but today when I switched it on, it's greeted me oddly, it allowed me to open my user id but after that it's been (kinda) hijacked.

The mouse cursor is blinking continuously, the trackpad on my PC refuses to allow me to move the mouse, even the keyboard hasn't been responding and it's been like that since the last 15 minutes

I've been unsuccessful in even shutting off my laptop, and now the only option left is to cut the power supply.

How to fix this problem?

The dialog boxes

closed as off-topic by bain, Eric Carvalho, Luis Alvarado Jul 25 '14 at 0:23

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – bain, Eric Carvalho, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Are you able to use tty by Ctrl+Alt+F2 ? – Pandya Jul 13 '14 at 6:18
  • Yes, I have logged in here but don't know how to use this – Nib Jul 13 '14 at 6:24
  • When I try to use any app, it says gtk-warning: cannot open display – Nib Jul 13 '14 at 6:26
  • Try to remember what you did yesterday. Probably something that required sudo. – Registered User Jul 13 '14 at 6:40
  • No changes need info sudo were made, except I installed a few updates to the OS that were around 143 MB, @RegisteredUser – Nib Jul 13 '14 at 6:41
1

Somehow the updates had been interrupted, due to which the packages were not properly configured.

To fix this problem, login through tty(CTRL+Alt+F1)

and type the command,

sudo dpkg --configure -a

This should fix all problems.

  • Umm, is there something wrong with the answer, I mean, why was it downvoted ? – Nib Jul 15 '14 at 9:59
0
# pip install xinput

Can u install this through command line and list all input device

# xinput list

if it disabled mean enable by like this

# xinput set-prop <device_id> "Device Enabled" 0

try this

  • Never mind, the problem was solved with assistance from @RegisteredUser – Nib Jul 13 '14 at 7:11
  • thats fine @Nib – Premkumar Jul 13 '14 at 7:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.