1

Recently, my window decorations disappeared from Compiz in Gnome Flashback. I asked about this, and someone helpfully suggested I could get them back by putting metacity --replace in my list of startup applications.

This worked, however, I did not realize until later, that running Metacity in this way would run in place of Compiz, making all Compiz features and functions cease to be available.

Another answer here on AskUbuntu suggested I use put gtk-window-decorator --replace in the Window Decorations section of the CompizConfig settings manager. However, this also doesn't work, and if I run it from the command line, I get:

gtk-window-decorator: error while loading shared libraries: libmetacity-private.so.0: cannot open shared object file: No such file or directory

How do I keep Compiz running and have window decorations?

2

Seems you experience some instability with Compiz

  1. Install Compiz Config Setting Manager (ccsm):

    sudo apt-get install compizconfig-settings-manager
    
  2. Open it. Preferences → Profile & Backend tab: Reset to Defaults

  3. Restart the session:

    sudo restart lightdm
    

Now, to activate extra plugins, it's better to do that single plugin each time. In case you still facing same issue, switch to tty1 (terminal) Ctrl+Alt+F1 or open gnome-terminal then restart compiz:

compiz --replace --display :0 --sm-disable

To watch for errors.

libmetacity-private.so.0 has been updated to libmetacity-private.so.1 in ppa:eugenesan/ppa which I believe you are using from mentioned posts. Use Synaptic to force downgrade. or through CLI:

$ apt-cache policy libmetacity-private0a

libmetacity-private0a:
  Installed: 1:3.12.0-0~eugenesan~trusty5
  Candidate: 1:3.12.0-0~eugenesan~trusty5
  Version table:
 *** 1:3.12.0-0~eugenesan~trusty5 0
        500 http://ppa.launchpad.net/eugenesan/ppa/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     1:2.34.13-0ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

$ sudo apt-get install --reinstall libmetacity-private0a=1:2.34.13-0ubuntu4

It may fix decorator problem. BTW, that PPA brought many issues for you, why you are keep it on. Better to disable it when you don't need it, and make only selective upgrade from it.

| improve this answer | |
  • Thank you for this response. However, resetting to defaults did not bring the window decorations back. – Questioner Jul 13 '14 at 3:46
  • Thanks for the update. I tried the command sudo apt-get install --reinstall libmetacity-private0a=1:2.34.13-0ubuntu4, and the response I get is The following extra packages will be installed: libmetacity-private0a, but then it doesn't seem to actually do anything. No download, no install progress. It just comes back to the command prompt, and nothing changes. Also, I removed the eugenesan repository. I don't remember why I originally used it. – Questioner Jul 13 '14 at 4:10
  • 1
    The problem has been solved now. After I removed the eugenesan repository, I had some errors with some broken packages, and I had to go use Synaptic to remove a bunch of packages that came from eugenesan. After I did that, and reinstalled Compiz and Metacity and associated packages, and then re-logged in, everything seems to be back to normal. I guess you were right - eugenesan was the problem all along. Thanks for all your assistance. – Questioner Jul 13 '14 at 4:25
  • 1
    I ended up completely purging all packages from eugenesan, and this ended up solving another problem I had. I had a question with a 50 point bounty on it, and I feel that since you provided the solution, you should get that bounty. If you a put an answer on this question, essentially saying "purge the eugenesan repository", I'll award the bounty to you. – Questioner Jul 13 '14 at 5:40
  • 1
    @DaveMG :) kind of chain reaction. I add an answer. – user.dz Jul 13 '14 at 6:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.