3

I'm having some trouble with my new Xubuntu 14.04 installation's clock. It seems to be lagging behind by an hour. the date and hwclock commands are reporting the correct time. I even tried to change my timezone to a different one and the clock didn't change at all. Any help on fixing this issue would be greatly appreciated.

Thanks.

1
  • Have you checked the clock's settings? (Right-clicking it.)
    – edwin
    Commented Jul 13, 2014 at 1:34

3 Answers 3

9

Found an odd fix to the issue. I had to first remove the clock from the panel, then change the time to what I want, then re-add the clock to the panel.

4
  • 2
    I can't believe this worked, but it did. Thanks!
    – Brian
    Commented Oct 23, 2016 at 4:17
  • Worked for me too. So absurd. Lost hours on this annoyance trying to fix it. Commented Jan 24, 2017 at 4:48
  • I had this same issue on Manjaro Linux 18.1.0, with xfce4-panel v. 4.14.1-0.1, and this solution worked for me. Thank you! :)
    – Aces
    Commented Sep 28, 2019 at 7:23
  • Thought it worked until I entered the timezone again. This messes up everything again. Tried disabling sync with Internet but even on manual the clock shows incorrect time. Using date in the terminal gets me the correct result, so it's not a system wide issue. Commented Mar 31, 2020 at 6:57
1
  1. Right-click on the clock in the panel
  2. Select Properties
  3. Update the timezone (it seems to use its own timezone)
1
  1. Right-click on the clock in the panel
  2. Select Properties
  3. In the "Clock Options" change the format from custom format (which defaults to an empty string causing this problem) to any of the options in the selector

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .