1

I'm using Ubuntu 14.04 , and I've used the 12th edition and 13th and it was always the same problem for me, java is NOT working on any of my browser : all applets aren't functional, I can't login to some websites and I can't get any of the codepens to work (all I get is "Loading...........") ..etc

I downloaded and installed OpenJDK 1.7.0 and that's what I get when I use the

java -version

in terminal:

java version "1.7.0_55"
OpenJDK Runtime Environment (IcedTea 2.4.7) (7u55-2.4.7-1ubuntu1)
OpenJDK 64-Bit Server VM (build 24.51-b03, mixed mode)

I have installed IcedTea using the software center

I'm in Syria, So I can't use Oracle.com.

1

You should try enabling java in your browser.

enter image description here

enter image description here

  • thanks for the answer, but here is the thing: I can't find any JAVA plugins on Chrome. and on firefox I can find IcedTea Plugin but No JAVA.. how is this possible when I've already downloaded Java? – Ziad Jul 13 '14 at 2:34
  • Java pulgin for firefox is icedTea it enable java to run on firefox – Sudheer Jul 13 '14 at 2:41
  • well IcedTea is enabled but still no result – Ziad Jul 13 '14 at 6:51
  • and why I can't find a Java plugin in my Chrome Plugins page although I have Java Downloaded and Installed already? – Ziad Jul 13 '14 at 6:56
0

Just install the 32bit version of OpenJDK / IcedTea

That should do the trick, most browsers are still 32bit even when the OS is 64bit

However from experience I do know some websites Java Apps are picky and don't like non Sun/Oracle Java Runtimes.

0

What helped me get mine running on 12.04, after nothing else helped, was to make sure I had everything installed. I had IcedTea Web Control Panel, OpenJDK Java 7 Runtime and OpenJDK Java 6 Runtime. But what I didn't have but needed was the "Icedtea Java Plugin" which I installed via the Software Center. Upon restarting my browser (Firefox) I was able to run the Java applets from the PHeT site.

0

Try the solution offered here: Java applets crashing in 14.04 and 14.10

It worked in Ubuntu 14.10 to allow PhET java-based simulations to run. The Java that is in the Ubuntu 14.10 repositories didn't work with PhET but the Oracle Java does (as of 2015/2/3).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.