So, I got a new laptop some days ago, and as usual I formatted it to install Ubuntu. I downloaded 11.04 and burned it on my pendrive using my old laptop (running 11.04).

When I tried to boot from the LiveUSB on my new laptop, it just showed me some weird graphics and if I select any option (can't see what I'm selecting), it gives me a black screen and that is all. Then I tried to boot with this LiveUSB on my old laptop, and it worked just fine ._.

I burned a CD with Ubuntu 11.04 (64-bit) and the problem continued. Then I thought it could be my CD driver, since the laptop is new and all... burned a Windows 7 64-bit DVD and it worked just fine. Also, if I check the CD/pendrive inside Windows 7, all the files there are OK.

Anyone have any idea of what can be? I found lots of questions about this, but none of them had the weird menus I'm getting ._.

Oohh... I also get a "prefix is not set" before the weird menu appears :S

My system specs: Intel Core i5 2400 Intel HD 3000 4gb DDR3

enter image description here

If anyone can help, I will be really grateful ._.

  • Have you tried booting LiveCD/USB sessions with other Linux distros or older versions of Ubuntu to see if you get the same problems? – Christopher Kyle Horton Jun 20 '11 at 19:08
  • Also, you mentioned your system specs above, but can you list the exact manufacturer and model of the laptop? That could be useful. – Christopher Kyle Horton Jun 20 '11 at 19:09
  • I have the EXACT same problem. Mine's an Intel Sandy Bridge i7-2630QM. I can boot Win 7 64bits and Ubuntu 10.04 64bits, but no luck with Ubuntu 10.10 or 11.04 64bits. I tried 10.10 and 11.04 32bits versions and it worked perfectly - but I do not intend to keep a 32bits OS. – user22262 Jul 26 '11 at 16:31
  • Try using the alternative iso. ubuntu.com/download/ubuntu/alternative-download – user606723 Jul 26 '11 at 16:56
  • dude i have the same problem with my new samsung qx-511 its a 64bit installation bug, as i have seen many people with new laptops have the exact same problem. f something doesnt work, i am tired of reading it as a solution. Every option results in black screen one friend suggested installing 32 bit but having one more partition for the home folder, so when the bug is resolved i can format previous linux partitions and install 64bit without loosing anything – user22721 Aug 3 '11 at 12:17

Sorry for not comming back here... forgot.

Anyway... when i'm using ElementaryOS "Jupiter" (based on ubuntu 10.10) and that one installs just fine. Ubuntu 11.10 Alpha 3 also installed, but gave me the same weird graphics on install... but after i pressed enter on the first choice, it installed so it's fine.

I don't know what tweak the guys from Elementary team made, but it worked prety fine. My guess it's something kernel related... dunno. It seems ubuntu 11.04 comes with mesa 7.10 while the support for Sandy Bridge is on 7.11.


Can you try doing a test on the laptop's RAM? If there's two sticks, try removing one and see if the CD will boot. If it does not try removing the other. I've had hardware issues (RAM, CD-Drive, HDD, etc) where the media from one OS will work fine, while others will not.

  • Can't open it, or i lose warenty :S – Julian Fernandes Jun 20 '11 at 15:15
  • You could try testing the RAM using memtest86+ (no installation or opening the case necessary), but if you can't boot a LiveCD/USB session then I'm not sure how viable that would be. – Christopher Kyle Horton Jun 20 '11 at 19:01
  • Yeah... i guess i will mess a little with the BIOS to see what i can do. – Julian Fernandes Jun 20 '11 at 22:49
  • Who said opening the laptop voids your warranty? Who manufactured the system? – Thomas Ward Jul 20 '11 at 19:31

Ok try this. when booting continuously press any key. It will help to show ubuntu language menu. Now select language and you are in main page [try ubuntu, install, etc]. Press F6 will show a drop-down box. select nomodeset [will show x sign]. press esc and select 2nd option install ubuntu. Hope this will help.

  • it is 11.04 problem. I think 10.10 will work fine. – shantanu Aug 3 '11 at 12:33

Not the answer you're looking for? Browse other questions tagged or ask your own question.