I was in my home folder and I moved my .minecraft folder to the desktop and it disappeared! I know it is still because if i create a new folder called .minecraft on the desktop, it says I can't do that because there is already a folder called that on the desktop. I have very little Ubuntu experience and I am running 12.04 unity.

Do you have any idea of how to get it back?


2 Answers 2


In Linux, folders and files starting with a dot are not displayed by default. A ls -al will show them in the terminal. In many GUIs, ctrl-H will show the hidden files. For the Desktop, I am not so sure (I use Xfce4). I can assure you that the folder is in you ~/Desktop, it is just not displayed


Files starting with . are hidden files. If you create a file with . Ubuntu hides that file. You can view hidden files from terminal and in Nautilus File manager.

From Nautilus file manager: press


It will be temporary after you close nautilus file manager it will be back to default hidden.

To make it permanent : open nautilus file manager

goto edit -> preferences -> in views select show hidden files and backup

From Terminal: go to the directory where file is there and enter

cd ~/Desktop

ls -a

Not the answer you're looking for? Browse other questions tagged or ask your own question.