1

I have a very recently installed Ubuntu box and the only change I have made is change the hostname to mail and hosts file now says:

127.0.0.1   localhost
127.0.1.1       mail

Anyway if I attempt to login via ssh (this is from a Windows 7 box) I login like this:

C:\Users\angus>ssh -vv acomber@192.168.0.52
OpenSSH_5.4p1, OpenSSL 1.0.0 29 Mar 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.0.52 [192.168.0.52] port 22.
debug1: connect to address 192.168.0.52 port 22: Connection refused
ssh: connect to host 192.168.0.52 port 22: Connection refused

So doesn't work.

I can ping the host ok.

Here is my /var/log/auth.log file:

acomber@mail:~$ tail -f /var/log/auth.log
Jul 12 11:52:56 mail compiz: PAM unable to dlopen(pam_kwallet.so):  /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 12 11:52:56 mail compiz: PAM adding faulty module: pam_kwallet.so
Jul 12 11:52:56 mail compiz: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "acomber"
Jul 12 11:58:40 mail compiz: gkr-pam: unlocked login keyring
Jul 12 12:13:44 mail compiz: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jul 12 12:13:44 mail compiz: PAM adding faulty module: pam_kwallet.so
Jul 12 12:13:44 mail compiz: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "acomber"
Jul 12 12:14:04 mail compiz: gkr-pam: unlocked login keyring
Jul 12 12:17:01 mail CRON[3639]: pam_unix(cron:session): session opened for user root by (uid=0)
Jul 12 12:17:01 mail CRON[3639]: pam_unix(cron:session): session closed for user root

What does this mean: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "acomber"

Do I have to specify password on ssh login?

I am new to Ubuntu and so I expect it is something pretty basic that is wrong.

What should I be checking from here?

UPDATE

Thanks for the tip saiarcot895. If I attempt to login locally by ssh -vv acomber@localhost I get:

acomber@mail:/etc/ssh$ ssh -vv acomber@localhost
OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: connect to address 127.0.0.1 port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused

But I can login ok using Xterm. so I assumed on the localhost I could connect ok.

That's confusing me because /etc/ssh/ssh_config is for the ssh client configuration? I thought it must be a problem in ssh server config? By the way, where do I look for ssh server config?

MORE INFO

acomber@mail:/etc/ssh$ ps aux | grep ssh
acomber   2095  0.0  0.0  10616   316 ?        Ss   12:47   0:00 ssh-agent -s
acomber   2978  0.0  0.0  15948   916 pts/1    S+   13:08   0:00 grep --color=auto ssh


acomber@mail:/etc/ssh$ netstat -l | grep ssh
unix  2      [ ACC ]     STREAM     LISTENING     13527    /tmp/ssh-joANPbVpPNT3/agent.2094
unix  2      [ ACC ]     STREAM     LISTENING     14292    /run/user/1000/keyring-M9AniG/ssh

How does XTerm work then? I assumed it must connect to an ssh server???

  • Note the times on the messages you referenced. That message was at least 4 minutes ago, and compiz is related to drawing the graphics. Also, on an SSH login, you will need to authenticate yourself in some way (either a publickey or a password), but it will prompt you for the password, rather than completely fail. This seems to be a connection issue. Have you tried SSH'ing locally on the remote machine (e.g. ssh 127.0.0.1 on the remote machine)? – saiarcot895 Jul 12 '14 at 11:49
  • Your session ends before the connection is even established, i.e. before logins and passwords are sent. Is your ssh server running? You can find that out by doing ps aux | grep sshd and netstat -l | grep ssh. – Jos Jul 12 '14 at 12:05
  • I found this link – Lety Jul 12 '14 at 12:22
  • Your ssh server is not running. ssh-agent is running but it is not a server. Furthermore, there is no process connected to the ssh port 22. Start a server process with /usr/sbin/sshd -D. – Jos Jul 12 '14 at 12:55
2

You don't seem to have a running ssh server. If this is a fresh installation, it is likely that none is installed.

  1. Install an ssh server.

    sudo apt-get install openssh-server
    
  2. If the server is already installed, start it:

    sudo service ssh start
    

You should now be able to log in normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.