0

I cloned the Git repository git://anonscm.debian.org/pkg-cli-apps/packages/monodevelop-database.git and tried to run ./configure but it gives me this error:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to enable maintainer-specific portions of Makefiles... no
checking for mono... /usr/bin/mono
checking for dmcs... /usr/bin/dmcs
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for UNMANAGED_DEPENDENCIES_MONO... yes
checking for mono... /usr/bin/mono
checking for dmcs... /usr/bin/dmcs
checking for msgfmt... /usr/bin/msgfmt
checking for msgmerge... /usr/bin/msgmerge
checking for MONO_ADDINS... no
configure: error: Package requirements (mono-addins >= 0.4) were not met:

No package 'mono-addins' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables MONO_ADDINS_CFLAGS
and MONO_ADDINS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

I am running MonoDevelop Version 4.0.12 and Mono 3.2.8 (Debian 3.2.8+dfsg-4ubuntu1).
What error is this and what do i do to resolve it?

0

It seems you don't have the mono-addins package from this line: No package 'mono-addins' found

Install it using this command in the terminal and then try again:

sudo apt-get install mono-addins

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.