2

After upgrade 12.04 64bit LTS to ubuntu 14.04 64bit LTS have problems with libxml2.

Can't run software center,empathy etc

# software-center
 Traceback (most recent call last):
  File "/usr/bin/software-center", line 128, in <module>
   from softwarecenter.ui.gtk3.app import SoftwareCenterAppGtk3
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 106, in <module>
   from softwarecenter.ui.gtk3.panes.installedpane import InstalledPane
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/installedpane.py", line 34, in <module>
   from softwarecenter.db.categories import (CategoriesParser,
  File "/usr/share/software-center/softwarecenter/db/categories.py", line 30, in <module>
   import lxml.etree as ET
ImportError: /usr/local/lib/libxml2.so.2: version `LIBXML2_2.9.0' not found (required by /usr/lib/python2.7/dist-packages/lxml/etree.so)

or

# empathy
empathy: /usr/local/lib/libxml2.so.2: version `LIBXML2_2.9.0' not found (required by /usr/lib/x86_64-linux-gnu/libxslt.so.1)

Did

# locate libxml2.so
/opt/openoffice4/program/libxml2.so.2
/usr/lib/i386-linux-gnu/libxml2.so.2
/usr/lib/i386-linux-gnu/libxml2.so.2.9.1
/usr/lib/vmware-installer/2.1.0/lib/lib/libxml2.so.2
/usr/lib/vmware-installer/2.1.0/lib/lib/libxml2.so.2/libxml2.so.2
/usr/lib/vmware-vmrc/5.1/lib/libxml2.so.2
/usr/lib/vmware-vmrc/5.1/lib/libxml2.so.2/libxml2.so.2
/usr/lib/x86_64-linux-gnu/libxml2.so
/usr/lib/x86_64-linux-gnu/libxml2.so.2
/usr/lib/x86_64-linux-gnu/libxml2.so.2.9.1
/usr/local/lib/libxml2.so
/usr/local/lib/libxml2.so.2
/usr/local/lib/libxml2.so.2.8.0

or

# sudo dpkg --list | grep libxml2
ii  libxml-libxml-perl       2.0108+dfsg-1                                       
ii  libxml2:amd64            2.9.1+dfsg1-3ubuntu4.3                              
ii  libxml2:i386             2.9.1+dfsg1-3ubuntu4.3
ii  libxml2-dev:amd64        2.9.1+dfsg1-3ubuntu4.3
ii  python-libxml2           2.9.1+dfsg1-3ubuntu4.3        
ii  python-lxml              3.3.3-1ubuntu0.1                                    
ii  python3-lxml             3.3.3-1ubuntu0.1

or

sudo apt-get install --reinstall libxml-libxml-perl

Warning: program compiled against libxml 209 using older 208
Warning: XML::LibXML compiled against libxml2 20901, but runtime libxml2 is older 20800
update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX with priority 50...
Warning: program compiled against libxml 209 using older 208
Warning: XML::LibXML compiled against libxml2 20901, but runtime libxml2 is older 20800
update-perl-sax-parsers: Updating overall Perl SAX parser modules info file...
Replacing config file /etc/perl/XML/SAX/ParserDetails.ini with new version
3

I had the same problem after upgrading debian squeeze to jessie, and then further to unstable. The problem is, that you have an old version of libxml2 library in your local folder /usr/local/lib.

You most likely have the correct version installed by your package manager in /usr/lib/x86_64-linux-gnu/, however library in local folder has a higher priority and in the end is the one that is loaded.

If all my assumptions are correct, you should be able to resolve by running the following by root:

# mv /usr/local/lib/libxml2* /

Then try to run empathy or other applications that were experiencing problems. If everything works fine, you can delete unused old libraries by running:

# rm -f /libxml2*
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.