3

My system: Lenovo t431s, 12.04. LAMP stack (it's used for web development), otherwise pretty vanilla.

Applications occasionally freezes when accessing the home folder.

I think I saw advice suggesting a reboot when this happens, but I can't find that page again.

Take with a grain of salt, I don't think it is related to any GUI because it also happens in the terminal. In the case of being in terminal, if I "ls" in ~/, it stops responding. It's not happening now, so I can't remember if Ctrl-C restores control.

It's intermittent: usually I have no trouble, but once the home folder becomes unavailable, it doesn't come back. What I mean by that, even when opening Nautilus, another terminal window, etc., I won't be able to see the files in the home folder until I reboot.

I realized yesterday that this problem also causes trouble with apps. I installed EasyTag and it always locked up. I figured out that EasyTag locked up because it was trying to read my home folder, and I fixed it by changing the default directory.

Is this a well-known problem (it's an old version) with a well-known solution? I can't find it. I could upgrade to 14.04, but without seeing a discussion of the problem, I can't be sure it's fixed there. I don't want the potential hassle of an upgrade without some reasonable expectation that it fixes the problem.

  • If your HDD supports SMART, run some diagnostics with GSmartControl (you can install it through software center). You may have a hardware issue. Also check the file-system integrity with fschk – hmayag Jul 11 '14 at 10:10
3

My fstab file mounts several shared folders on my home network to folders in my home directory. When I take my laptop out, the links are broken.

I only noticed the problem when I attempted to use a program that wanted to read my home directory. Since I don't do that often, the issue felt intermittent.

Remove those lines from the fstab, and to make a script file (and launcher) to mount those folders when I need them.

2

The most likely problem is that your filesystem is either corrupted or is not optimal for Linux (like NTFS) which produce that effect. Also a failing disk can produce the same effect. To verify neither of those reasons affect you, you must from a Live Environment run fsck on the affected partitions (ie. sudo fsck /dev/sda1) and check the SMART values with a SMART tool (ie. sudo smartctl -a /dev/sda).

Is important that you create a backup of all your important data somewhere safe, preferable that can be unplugged of the system.

  • I set up my computer with an ext4 partition for /home on /dev/sda3. – chuckj Jul 12 '14 at 1:00
  • (The five-minute edit limit expired while I was looking for a flash drive.) The partition passed smartctl, though I'm not able to interpret the detailed results. I'm not sure how I should run fsck. Since the computer is running, fsck warns of certain (inevitable?) dire consequences if I continue. Would you normally do this with a live-usb? (I would have tried it already if my kids hadn't stolen all of my flash drives.) – chuckj Jul 12 '14 at 1:06
  • @chuckj you must do it while the partition is not mounted. If it's mounted fsck will refuse to run. – Braiam Jul 12 '14 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.