14

EDIT: Just look at the accepted answer. I wasn't how it worked at the time of writing so I just guessed below.

I am new to Linux so this might be a noob question. I am trying to install a new web browser called breach which is built in JavaScript specifically Node.js, and I wanted to try hacking on it a little bit.

I installed the tar folder from off of their site and I have a folder called AUTO_UPDATE_BUNDLE and a file called breach.sh I believe the breach file is a bash script and I was guessing that's how I install it. (I have no idea if that's correct though.)

So I looked up online how to run a bash script. I went in the terminal and this is what I wrote while in the directory of the breach.sh file.

sh breach

I got this error.

[3428:3428:0710/191300:858123323:FATAL:browser_main_loop.cc(172)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
Aborted (core dumped)

I then navigated to the link to code.google.com/... above and it said

We need a SUID helper binary to turn on the sandbox on Linux.

In most cases, you can run build/update-linux-sandbox.sh and it'll install the proper sandbox for you in /usr/local/sbin and tell you to update your .bashrc if needed.

I don't understand how I can run build/update-linux-sandbox.sh. Is build a directory in my root directory? I tried searching for it there but I couldn't find it.

I would appreciate any help, and if I'm heading the wrong direction with properly installing this browser than correct me where I am wrong. Thanks in advance.

0

2 Answers 2

13

Since you need a setuid sandbox to run breach you basically have two options:

  1. Use the one provided by chromium-brower (recommended method):

    sudo apt-get install chromium-browser
    

    Go to the breach folder (e.g breach-v0.3.20-alpha.5-linux-x64) and type the following command:

    CHROME_DEVEL_SANDBOX=/usr/lib/chromium-browser/chrome-sandbox ./breach
    
  2. Follow the instructions provided here: Building Breach from Source.

    Note that you'll first have to build the ExoBrowser.

    As you need the chromium source code to build it, use the chromium depot_tools fetch command to get it.

enter image description here

UPDATE:

If (like me) you have downloaded the breach alpha in your ~/Downloads folder you can set an alias to run breach as follow:

alias breach='export CHROME_DEVEL_SANDBOX=/usr/lib/chromium-browser/chrome-sandbox && ~/Downloads/breach-v0.3.20-alpha.5-linux-x64/breach'

Copy this command to your ~/.bashrc to keep this alias.

Note: adjust the path to the breach startup script for your needs.

2
  • Hey thanks for the answer. I got it installed, but one question. Do I have to run this command CHROME_DEVEL_SANDBOX=/usr/lib/chromium-browser/chrome-sandbox ./breach every time I want to start breach up? Is there a way to build a shortcut or something? Even a reference would be nice.
    – John
    Jul 15, 2014 at 3:08
  • 1
    @John: I've updated my answer with an alias to put in your ~/.bashrc Jul 15, 2014 at 7:13
3

If you have google chrome installed, do

export CHROME_DEVEL_SANDBOX=/opt/google/chrome/chrome-sandbox

just before you run breach with

./breach

Essentially, this is a shortcut to running build/update-linux-sandbox.sh mentioned there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .