1

I have a lenovo ideapad z570 laptop with BCM4313 adapter...

$ lspci -vvnn | grep 14e4
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
    Subsystem: Broadcom Corporation Device [14e4:051b]

Based on the several posts available online for this adapter, I have so far tried various combinations of different drivers available.

Finally, I'm at the 2nd solution offered in this page... Installing Broadcom Wireless Drivers

i.e. I'm using brcmsmac module. Blacklisted the following...

blacklist b43
blacklist bcma
blacklist wl
blacklist ssb
blacklist acer_wmi

Added brcmsmac to /etc/modules list.

But my rfkill listing still shows the interface to be hardware blocked...

$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes <<<<
1: ideapad_bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

But my hardware switch seems to be on. (There is a single switch for bluetooth and wifi, and bluetooth is working fine)

dmesg shows error during brcmsmac driver loading...

$ dmesg|grep brcmsmac
[   16.664016] brcmsmac bcma0:0: mfg 4bf core 812 rev 24 class 0 irq 17
[   16.698271] ieee80211 phy0: registered radio enabled led device: brcmsmac-phy0:radio gpio: 243
[   25.018128] brcmsmac bcma0:0: brcms_ops_start: brcms_up() returned -132

After some googling, I see that 132 errno corresponds to ERFKILL, indicating that the interface is hardware blocked.

So, is this really a hardware problem? Or some bug in driver code? Any suggestions on how to conclude, without having to try other OSes to check?

0

The module bcma is a dependency of brcmsmac; I suggest you undo its blacklist. Also, I'd try blacklisting ideapad-laptop and not acer-wmi.

  • Tried this combination too. Didn't help. The driver fails with same error message as above. rfkill listing still shows hardware blocked. unblocking doesn't help. – nspmangalore Jul 11 '14 at 5:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.