110

I read through all the related answers, but they do not apply to Ubuntu 14.04.

I have no .gnome2 folder and no Passwords and Encryption keys item in the system settings. I tried to crawl through every possible menu, but I could not find out how to do it.

The popup usually pops out when I start Chromium.

  • 1
    Exactly what answers you read and what is the dialog that appears? Google Chrome now has a thingy about an API keys, which could be the reason of the dialog. – Braiam Oct 5 '14 at 15:17
  • @Braiam The popup is "Enter password to unlock your login keyring\n The login keyring did not get unlocked when you logged into your computer.". But it is ok, the accepted answer solved the problem. – Martin Drozdik Oct 6 '14 at 3:56
  • @gsamaras The question you suggest is slightly different. It asks about popup at boot, while I ask about regular popups, mainly during the start of Chromium. – Martin Drozdik May 26 '16 at 7:28
  • I agree @MartinDrozdik (you got my upvote already:) ) – gsamaras May 26 '16 at 16:02
56

Fire up "User Accounts", set "automatic login" to "off". At startup you will be asked your user/password only once; popups like "unlock keyring" will never pester you again.

  • 15
    Not true unless you seek out the keyring and tell it to use the "login" keyring instead of the "default" keyring. :P – Chris K Dec 10 '14 at 3:50
  • 11
    I have never, never set my user account to automatic login . . . ever – mchid Aug 10 '15 at 5:00
  • 16
    this is not true. I never had automatic login on and get the same problem, turned it on/off and it made no difference at all. ubuntu 14.04.03 – Eric Oct 2 '15 at 17:05
  • 32
    It is not the solution, because I want to have automatic login and don't want to see login keying – Abrar Jahin Mar 22 '16 at 4:33
  • 9
    This is a workaround, not a solution for those that want automatic login. – JohnAllen Aug 14 '16 at 13:42
42

This is for 14.04

  1. Open the password/keyring manager from settings (or run it directly - seahorse)
  2. Ensure Menu > View > By Keyring is ticked.
  3. In the sidebar, under 'passwords' create a new keyring 'Unprotected' (or re-use an existing keyring, e.g. 'Default', but NOT 'Login' because that will make everything unprotected which you probably don't want)
  4. Right-click the new keyring, and 'set as default'
  5. Right-click the new keyring and set its password as empty (only needed if you adopted an existing keyring)
  6. In the 'Login' keyring, delete the network secret for your wifi.
  7. Go to the network manager and add the network again - its secret should appear in the default keyring, which has no password.
  8. Set the default keyring back to Login.
  • 7
    xfce does not have this option in the menu – Bhikkhu Subhuti Mar 14 '16 at 1:34
  • 1
    done 1-5 steps on 14.04 and the problem - seems gone: popups appeared in various apps, like IDE when entering passwords inside, ssh clients and so on. Thanks! – yetanothercoder Dec 27 '16 at 8:57
  • Under Kubuntu 14.04.5, how do I open the password/keyring manager? "User Accounts" under "System Settings" doesn't do it. – Paul A. Apr 6 '18 at 20:48
12

Instructing Chrome to avoid the keyring

This problem occurs because Chrome wants to store usernames/passwords in the keyring (so they are encrypted). Therefore, every time you open Chrome, it tries to unlock the keyring.

You may instruct Chrome to do not use the keyring. If you do that, Chrome will not try to unlock the keyring again.

To run Chrome without using the keyring, you may use the option --password-store=basic:

$ google-chrome --password-store=basic

Modifying the Chrome launcher (icon) to avoid the keyring

Considering that you usually run Chrome doing a doble-click on an icon, you must change the command for the icons you use to include the additional option to run chrome in this way all the time. You may edit (1) the global launcher in the /usr/share/applications/google-chrome.desktop folder or (2) the personal launcher file located in the ~/.local/share/applications/ directory.

  1. Edit the launcher file. For instance, using gedit

     sudo vi /usr/share/applications/google-chrome.desktop
    
  2. Modify the Exec= line to include the --password-store=basic option

     Exec=/opt/google/chrome/google-chrome  (...)  --password-store=basic                    
    
  • 3
    password-store=basic means that all you Chrome password will be stored in plain text which is unsafe. This answer isn't good at all. – tamerlaha Aug 1 '18 at 10:20
  • 2
    It is a good answer if you do not store passwords in chrome – Marco Altieri Sep 24 '18 at 11:10
  • --password-store=basic also works for other applications like opera. Similar to Marco I don't want to store passwords in my browser so this is a reasonable option for me and possibly others. – scai Dec 27 '18 at 14:43
  • Whilst running /usr/bin/google-chrome-stable --password-store=basic does solve the issue, editing the .desktop files you mentioned does not. At least not in 18.10 The "solution" is to set an empty password on your "Login" keyring (not your user). – Marc Jan 3 at 14:44
2

It started popping up (after every logout) ever since I logged-in with new password.

In my case possword had been changed during my medical leave and once I came back, i changed the new password to my old login password(i remember that easily ). It ended.

I changed my password using

sudo passwd vimal

gave changed password for sudo, the current login. and then new password (my old password, typed twice)

Shut-down.

And it did not come again!

1

Just remove / turn off your online accounts when not needed. I had the same problem and I solved this by removing my online account.

  • 6
    What online accounts is this talking about? – nobar May 14 '17 at 3:25
1

I know this question is rather old, but for me the cause was WiFi networks. The configuration utility for NetworkManager (right-click on nm-applet and choose "Edit Connections...") offers two ways to save a WiFi password - one is to use a keyring and the other is to save it internally. I had switched from using a keyring to saving it internally because I preferred the convenience of the latter method, however the password was still saved in the keyring which then wanted unlocking.

0

WARNING

This may work, but will likely cause your system to become insecure. Your passwords will be stored in an unencypted manner, and could be accessed without your knowledge.

Another answer in this question suggests disabling the autologin feature of Ubuntu - this achieves the desired result of preventing the system from asking for a password often, yet maintins a higher level of security.


Start the 'Passwords and Keys' program by opening the dash, and typing passwords.

Then right-click the first choice in the left menu, "Login".

Choose "Change Password".

Enter your current password, then press return (twice) to use a blank password.

The system will give you a warning about storing passwords unencrypted.

  • 13
    No, do not change your password to blank. This is not how to solve the problem. One's password should NEVER be left blank. I wish I knew the answer to the OP's problem but I'm looking for it too as it just started doing this with Xubuntu after installing owncloud. – Scott Moore Jul 31 '14 at 0:49
  • 1
    @ScottMoore It is painful having the security hole caused by setting the password on the keyring to a blank. If my computer were in a public setting of some kind, this would not be an answer that would work for me. – Charles Green Aug 3 '14 at 14:46
  • 2
    Indeed this answer is only valid for the 'grandma-uses-pc-and-gets-confused-by-all-these-password-thingies' situation. Which is precisely why I needed to fix it... But now her keyring is unprotected. Let's hope FIDO (en.wikipedia.org/wiki/FIDO_Alliance) will fix this paradox some day. – iGadget Sep 17 '14 at 19:54
  • 1
    @iGadget While I think it's sometimes okay to use a blank password for one's keyring, this is only appropriate when the user understands what's going on (and thus understands and is really choosing to accept the risk). – Eliah Kagan Oct 1 '14 at 13:03
  • @EliahKagan Well I don't think grandma will understand what is going on. What I do know is that she will NOT accept having to enter her password every time she starts her computer, being the only user of that computer and all... So a different solution is needed. – iGadget Oct 2 '14 at 14:12

protected by Community Feb 25 '15 at 12:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.