I have a Dell Inspiron 1525 laptop w/ Intel graphics:


00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated  Graphics Controller (primary) (rev 0c)

My TV is an Olevia 27" which shows up in the display settings as "Synaptics Inc 27".

My HDMI output worked perfectly fine up through 10.10 and kernel 2.6.35-29, but yesterday I upgraded to 11.04 and now I have problems. The output to my TV still works, though there are tons of "scan lines" and any time I move the mouse or drag an application to the tv (vlc for instance), the lines get worse and go crazy. In display settings the TV is set by default to 1360x768 @ 60Hz which has always been the default and worked just fine, until 11.03 w/ the 2.6.38-10 kernel. I believe the native resolution of the tv is 1366x768 but the 1360x768 always worked.

I did figure out that I can set the resolution to 1024x768 @75Hz and the scan lines go away, but this is not ideal. I tried reverting back to the 2.6.35-29 kernel to see if it worked as it originally did in 10.10, and the scan lines do not appear, however the display only takes up 3/4 of the TV, with the other 1/4 black and most certainly the border. Definitely even less ideal. So I'm back on the 2.6.38-10 kernel for now using the lower resolution. I also notice that when playing a video, the video appears to be just a few milliseconds behind the audio; not a huge delay but just enough to be noticeable.

After a lot of Googling I tried to use xrandr to add and set a new mode of 1366x768 @ 60Hz for the TV, but the lines remain. My xrandr output is as follows:

Screen 0: minimum 320 x 200, current 2304 x 800, maximum 8192 x 8192

LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1280x800       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  

VGA1 disconnected (normal left inverted right x axis y axis)

HDMI1 connected 1024x768+1280+0 (normal left inverted right x axis y axis) 600mm x 340mm
   1360x768       60.0 +

   1280x800       59.8  
   1280x768       59.9     60.0  
   1280x720       60.0  
   1024x768       75.1*    70.1     60.0  
   800x600        72.2     75.0     60.3     56.2  
   848x480        60.0  
   640x480        75.0     72.8     60.0     59.9** 

TV1 unknown connection (normal left inverted right x axis y axis)
   848x480        30.0 +
   640x480        30.0 +
   1024x768       30.0  
   800x600        30.0

So, does anyone know what might have changed in the new kernel/video drivers that would cause this behavior to change from it's previously perfect operation in 10.10 and below? TIA!

closed as too localized by Marco Ceppi Jan 19 '12 at 2:10

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Can you please read the label on your television and tell us what specific model you have? – Bruno Pereira Oct 6 '11 at 8:10

i'm not sure if the actual problem is the same, but i had to do some research for this exact same problem (although my gpu was nvidia, not intel) and what i had to do is create a custom EDID bin to specify the monitor device to Xorg

it is strange that it worked for you on 10.10 and it broke at 11.04. I actually had this problem on 10.10

in any case, here is the thread where i asked and eventually solved a similar issue: https://superuser.com/questions/280615/ubuntu-10-10-getting-appropiate-monitor-resolution-for-lcd-hdtv

  • Thanks for the info and answer! Yes it has worked flawlessly since I first plugged it in. Never had to modify anything. I could probably go back to 10.10 and everything would work fine but I want to stay on 11.04 at this point :-/. I checked out that thread about creating the custom EDID.. I'm not sure that's my solution since this previously worked without additional config but I will do some research. Since I'm using Intel I don't have an xorg.conf file. I tried creating one but that threw a bunch of errors. Trying to figure out what "broke" it specifically in 11.04 O_o – Jason Jun 19 '11 at 21:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.