Can I remove the Anchor icon from my Docky dock?

  • I don't know of any way to do this. I think it is supposed to stay for access to your prefs.
    – user415
    Sep 30, 2010 at 11:13

4 Answers 4


In order to remove the anchor icon from docky, you must first upgrade to the most recent version. To do this, you need to add the development PPA to your list of software sources. On Ubuntu 9.10 and later, you may do this by typing:

sudo add-apt-repository ppa:docky-core/ppa

and then refreshing the list of packages with

sudo apt-get update
sudo apt-get upgrade

This may not trigger the update, in which case you should open Synaptic package manager, and search for docky. Finding the docky package, select it and use the menu item Package->Force Version. This will let you select the version of docky to install. The fix to remove the anchor icon requires version 1.0 or later.

Once you have the Docky-Core PPA version installed (the latest version is 2.2 against the 2.0.6 you find on the default repository), you may disable the docky icon by:

  1. Open gconf-editor by pressing Alt+F2 and typing gconf-editor.
  2. Navigate to apps/docky-2/docky/items/DockyItem.
  3. Deselect the ShowDockyItem key.
  4. Restart docky.

After you have disabled your anchor icon, you may still access your docky preferences by right clicking any dividers you may have on the dock.

  • 1
    The final instructions are the same as gamerchick02's, but its very important that you have the latest version of docky installed to do this.
    – Zoe
    Sep 30, 2010 at 15:28
  • I thought this would be a cool thing to do, so I tried it out... it took me a while to figure out how to get the correct version in.
    – Zoe
    Sep 30, 2010 at 19:18
  • Thanks for the answer... I couldn't have figured out the "upgrade to the most recent version" part.
    – User
    Sep 30, 2010 at 23:19
  • Great answer Zoe, I have been passively trying to figure out how to remove the anchor icon for a few days. This worked!
    – spoon16
    Nov 2, 2010 at 8:20
  • Like Matthew said below, you need to add the PPA repository even if you have a newer version. And it's simpler to just follow his answer, since we need to open the terminal anyway.
    – cregox
    Mar 8, 2011 at 16:38

Yes, from an OMG!Ubuntu article:

  1. Press Alt + F2
  2. Type command gconf-editor and hit enter/return
  3. Navigate to apps/docky-2/docky/items/DockyItem in the gconf-editor
  4. Uncheck ShowDockyItem
  5. Restart Docky

Hope that helps. Also, see the Launchpad bug that addresses the issue.

  • Thanks for the +1. I figured the bug report would help the OP. Sep 30, 2010 at 23:24

Run these three commands:

sudo add-apt-repository ppa:docky-core/ppa
sudo apt-get update && sudo apt-get upgrade
gconftool-2 --type bool --set /apps/docky-2/Docky/Items/DockyItem/ShowDockyItem false

This does the exact the same thing as Zoe's answer (add the PPA, upgrade to the latest version, and hide the anchor item), but all automatically. You will have to restart Docky after you finish.

  • As per your comment, neither updating Docky to 2.2 by adding the PPA nor running gconftool to force adding that setting into gconf-editor hided the Docky icon.
    – cregox
    Mar 8, 2011 at 16:46

gconftool-2 --type Boolean --set /apps/docky-2/Docky/Items/DockyItem/ShowDockyItem False

and restart Docky. Set final value to True to turn it back on. Worked fine for me on 12.10. Source

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .