0

Since I got a new computer and installed Ubuntu 14.04 (gnome edition) my PS3 & Xbox 360 controllers don't work anymore. I used to be able to use my PS3 controller in 12.04 using xboxdrv.

Xbox 360 Controller: If I push one of the trigger buttons on the Xbox 360 controller my mouse goes haywire. The mouse gets pushed to the left or right of the screen. The mouse also goes crazy if I don't hit a trigger button, but use the controller for about 1 min.

I am using xboxdrv. I run:

sudo rmmod xpad
sudo xboxdrv --detach-kernel-driver --mimic-xpad –silent

The problem is the same with and without the “--mimix-xpad” option.

PS3 Controller: If I run xboxdrv with the PS3 controller (worked in 12.04), the system doesn't recognize any buttons I push. There is a known bug in the kernel that Ubuntu 14.04 runs: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1326725

Users claim this was fixed in the 3.14 kernel. So I upgraded to the 3.14 kernel from Ubuntu Mainline (which I don't like to do), but the result is still the same.

I would really love some help. I have a fancy new Linux gaming machine and can't play my games. I even bought the Xbox 360 controller because the PS3 one stopped working. But that doesn't even work :(

1

I was able to fix the issue with the Xbox 360 USB controller forcing my mouse to fly across the screen by uninstalling: xf86-input-joystick and then rebooting.

This removed the ability for the joystick to control the mouse. I can now use the gamepad normally with xboxdrv:

sudo rmmod xpad
sudo xboxdrv --detach-kernel-driver --mimic-xpad –silent

I believe the PS3 controller not working in Ubuntu 14.04 will continue to be an issue until a kernel update fixes it.

0

nope. I just solved that one on 16 and debie jessie aka stable..you should have that one in a bag.

you need bluetooth drivers, check dmesg for fails... pluggable uses a specific broadcom driver you have to extract from sin and convert or get from me. im over at southern hedgehogs and will be updating today.

so get that working and install bluedevil, as blueman is buggy. hard wire the controller. get the sixaxis.c file on ubu forums. comile it in point flat seconds....chmod(can you run it?) and run that file.

now... unplug the controller and push the button. it auths with the pc like the ps3 but the pc needs to know the device is there. and your bluetooth driver is probly not working right, which is why its not working.

also: blueman tries but fails to notify you about the sync via bt after the hardwire sync. bluedevil doesnt have that problem. Its a part of kde but it works.

to disable the controller and save power at this point, disable and reenable the bt or unassociate it. the controller will then sleep. this isnt automatic, so be mindful if you dont wnat your battery draining.

as per wii: try the mayflower bar in mode 3. I had to switch to sin, install the update and it appeared. then I tried ubu and it worked. You may need to recompile all of the variant hard-to-source libs for dolphin but indeed it works also under linux. Due to the lightbar, the wii requires a wonky bt device, but if your bt is running ok, you can see the device with a plain-jane bt connector.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.