0

I am trying to copy a folder into the user/share/themes folder on Ubuntu 14.04, and it's telling me I cannot do this because I am not "owner". So I right-clicked the usr/share/themes folder > Properties > Permissions tab and tried to change the permissions but they're all greyed-out/disabled.

So then I opened up Terminal, entered groupmod TAB TAB TAB > sudo adduser jase root to try and get higher permissions or something - and it worked. I verified that I added myself as root by id jase. But that still didn't fix the problem. I still can't copy folders or files to usr/share/themes folder.

How can I do this? How do I become "owner"?

2

You copy the file using sudo

sudo cp file destination

For directories use th -R flag

sudo cp -R directory destination

If the files or directories have spaces, you have to quote or escape ( \ ) them

sudo cp "file with spaces" destination
sudo cp file\ with\ spaces destination

For information on Linux permissions and the use of sudo, see:

https://help.ubuntu.com/community/RootSudo

and

https://help.ubuntu.com/community/FilePermissions

|improve this answer|||||
  • I just tried that. With: jase@Jase-PC:~$ sudo cp '/home/jase/Downloads/flattastic_13_01_2014_by_nale12-d70zd5z' '/usr/share/themes' [sudo] password for jase: cp: omitting directory ‘/home/jase/Downloads/flattastic_13_01_2014_by_nale12-d70zd5z’ but then it didn't work. It said: "that it omitted something." – jay_t55 Jul 9 '14 at 22:37
  • I'm sorry but the link above - none of that stuff works. I've tried it a dozen times. And I'm not that new to linux (I've just been away from Linux for a while). Anyway, I've managed to solve it by entering sudo chown -R jase /usr/share/themes into terminal. I remember doing that last year. It's working just fine now. Thanks for your help :) – jay_t55 Jul 9 '14 at 22:41
  • That is not really a good idea (changing ownership and permissions of system files). You need the -R flag with cp for directories . cp -R directory destination. The error messages in Linux are (usually) helpful, if you do not understand them, post the command and error message. – Panther Jul 9 '14 at 22:52
0

You can't copy directories with cp in linux, unfortunately. The other answer is correct that you need root privledges with sudo, but you should do something like this to copy a directory:
cd /home/jase/Downloads
tar cvf flattastic.tar flattastic/
sudo mv flattastic.tar /usr/share/themes/
cd /usr/share/themes
sudo tar xvf flattastic.tar
sudo rm flattastic.tar

BUT, in your specific case, there's something else you can do, I think.

Try
cd ~
mkdir .themes
mv /home/jase/Downloads/flattastic/ ~/.themes/flattastic
You might have to log out and back in, but I think that this would let you add themes without using sudo or root privledges at all.

|improve this answer|||||
  • 1
    That is not true, use the -R flag for directories. cp -R /home/jase/Downloads/flattastic /usr/share/themes/ – Panther Jul 9 '14 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.