6

I can see the web pages I created in /var/www/html/ by typing localhost in URL bar.

A few months ago I could even access those pages by typing my ip address from other computers, but now I am getting server timed out when I type my ip address from my mobile phone; my friends are also not able to connect by typing my ip address.

Recently I installed webmin from a tutorial in unixmen, I thought maybe it changed read and execute permissions. so I executed the command chmod -R 775, but it didn't change anything (still not able to connect from other computers).

Everything is working fine from host computer.

The output of ifconfig is:

eth0      Link encap:Ethernet  HWaddr 08:9e:01:00:10:ad  
          inet addr:183.83.83.29  Bcast:183.83.127.255  Mask:255.255.192.0
          inet6 addr: fe80::a9e:1ff:fe00:10ad/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:443584 errors:0 dropped:0 overruns:0 frame:0
          TX packets:378897 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:470991396 (470.9 MB)  TX bytes:96527317 (96.5 MB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:154813 errors:0 dropped:0 overruns:0 frame:0
          TX packets:154813 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:20729684 (20.7 MB)  TX bytes:20729684 (20.7 MB)

pan1      Link encap:Ethernet  HWaddr 42:dd:4f:ed:a2:f2  
          inet addr:10.141.41.1  Bcast:10.141.41.255  Mask:255.255.255.0
          inet6 addr: fe80::40dd:4fff:feed:a2f2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:174 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:32909 (32.9 KB)
  • This sounds like a problem with your ISP, internet service provider. Do you pay for a static IP? If not, then it is probably because it had changed, and is now accessible from that new ip. Could you edit your question to include all of the output from executing ifconfig in terminal, and visit this website and tell us what it says. – Tim Jul 9 '14 at 19:00
  • Go to canyouseeme.org on the server and check if your port 80 is open – meccooll Jul 9 '14 at 19:02
  • Are we talking about access over a LAN or the internet? – Dan Jul 9 '14 at 19:07
  • From canyouseeme.org I got "Error: I could not see your service on 183.83.83.29 on port (80) Reason: Connection timed out" @meccooll – user41965 Jul 9 '14 at 21:11
  • access over internet @dan08 – user41965 Jul 9 '14 at 21:12
7

Thank you everyone, I think it was the firewall, by disabling the firewall as given in the site https://help.ubuntu.com/12.04/serverguide/firewall.html with the command:

sudo ufw disable

I could open the index page from mobile.

  • I wonder what security problems you have opened up, watch /var/log/auth.log serverfault.com/questions/244614/… – JimLohse Jan 24 '16 at 9:02
  • 1
    this "ufw" thing never worked for me, not matter what. Im using ubuntu 18. May be it helps other, for me it finally worked via "Firewall" ubuntu GUI application. – amit Mar 12 '20 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.