0

Description of the (original) issue

When I'm in the bottom-right workspace, pressing CTRL+ALT+Up+Left is supposed to take me to the top-left workspace - but it is impossible to switch to the top-left workspace by pressing more than one arrow at the same time.

Diagonal switching to other three workspaces (with simultaneous keypressing) does work.

For me to switch to the top-left workspace I have to literally use one arrow to move in one direction, then let it go, and then press the other arrow (all the while still holding CTRL+ALT).

For example, starting from the bottom-right workspace:

  1. Press CTRL+ALT+Up+Left together simultaneously -> nothing happens
  2. Let go of Up, Left while still holding CTRL+ALT -> switch to bottom-left workspace
  3. Press Up while still holding CTRL+ALT+Left -> nothing happens
  4. Let go of Left, press Up, while still holding CTRL+ALT -> switches to the top-left workspace

Ubuntu version 14.04. It works on a laptop with 14.04 however.

Updates

Update 1: I have just tried diagonal switching on the LiveCD - and it still doesn't work. I tried the same LiveCD on my laptop - and it does. This strongly suggests that it's not really a software issue - but I'm still not sure, and definitely need help figuring this out, because it's very annoying.

Update 2: After installing screenkey, I have noticed that the key combination of CTRL+ALT+Up+Left is not even registered. Here is what it looks like when I switch to the bottom-right workspace from the top-left one diagonally:

enter image description here

And when switching to the top-left one from the bottom-right one diagonally - nothing happens, and screenkey doesn't show any keys being pressed. I'm still investigating to find out whether this is a hardware issue - but all the individual keys (CTRL, ALT, Up arrow, Left arrow) are registered correctly.

Update 3: it works when I use a wireless Logitech keyboard.

Update 4: I ran showkey in one of the consoles, and this is what it looks like when I'm pressing the key combinations using the USB keyboard:

Switching to bottom-right workspace:

keycode 29 press CTRL
keycode 56 press ALT
keycode 106 press Right
keycode 108 press Down
keycode 106 release Right
keycode 108 release Down
keycode 29 release CTRL
keycode 56 release ALT

Switching to top-left workspace:

keycode 29 press CTRL
keycode 56 press ALT
keycode 29 release CTRL
keycode 56 release ALT

Notice the missing arrow key notifications.

  • So it works for the other directions, but just not up+left? – Seth Jul 9 '14 at 18:34
  • Yes, that's right. I'm on the top-left workspace right now, and pressing CTRL+ALT+Down+Right gets me there just fine. Then immediately pressing Up+Left (while not lifting CTRL+ALT) - leaves me where I am (the little switching graphic is still up). I can navigate back to top-left by individually pressing Up and then Left, and then I can again press Down+Right, and it works (all the while holding CTRL+ALT). I can move in any way I want, except diagonally to top-left, and it's really annoying in some situations. – jcora Jul 9 '14 at 18:41
  • Have you changed any shortcuts or defined any custom ones? – Seth Jul 9 '14 at 18:55
  • I might've, but I think I didn't. I inspected the keyboard shortcuts for switching workspaces, and they're correctly defined. I switched to a guest session, which should have separated settings and everything - and it also didn't work. – jcora Jul 9 '14 at 19:01
  • That sounds like a keyboard lag issue, or even you pressing them closer together than the others... – Tim Jul 9 '14 at 19:04
0

Edit: confirmed, have a new keyboard now which supports N-key rollover, functions as expected.

Well it seems like I have forgotten an old problem: keyboard rollover. Certain USB keyboards seem to have a limitation on certain key combinaions - and it would appear that my keyboard has one on a quite inconvenient spot. I think I'll start using the wireless keyboard that does not seem to have this specific problem.

You can read more about this on this SuperUser question.

I also noticed the following combinations do not work: CTRL+ALT: F+G, H+J, ;+', \+', Left+Up, 4+5, 6+7, 0+-. There are probably many more on that keyboard.

Any additional information welcome!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.