1

Upgrade from 12.04 LTS to 14.04 LTS on two computer running Ubuntu 14.04 LTS. One is a System 76 the other is an Apple min mac.

Problem:

In all application that have spell check turned on, LibreOffice, several IDEs the spell checker lost, forgot all the words I have add in to the spell checker over the last couple of years.

I think the problem is at the O. S. since all the applications broke on the upgrade to 14.04 LTS on both computers at the same time.

I tried checking askubuntu, Google and Duck Duck Go.

What Would like to Know is:

  1. What is the name of the primary spell checking tool used in Ubuntu? So I can check the documentation and know the file names.

  2. Where does Ubuntu keep the user “Dictionary”?

  3. Is their a default place Where Ubuntu moves files to during an upgrade?

I hope the Upgrade from 12.04 LTS to 14.04 LTS moved the default location user “Dictionary” and saved the old “Dictionary” somewhere.

Append 07/15/14

Reply to Aibara Iduas,

when the computers where 12.04 LTS their appeared to be a single dictionary for all the programs. The spell check just worked in all applications.

After I upgraded to 14.04 LTS, the dictionaries appeared to have been reset to zero added words. I lost all the added in words everywhere.

Reply to Braiam.

Thank you for the name I will check that out.

Reply to bodhi.zazen.

I do not think the problem is a bug because near as I can tell no one else had the same or similar problem with the upgrade. I more than likely screwed up the upgrade by forgetting to pass in a parameter and or messed up an answer during the upgrade.

Clarification:

The Upgrade to 14.04 LTS caused other problems, Getting the busy computer “spinner” a lot more than before, plus a few other problems.

I decided to try to fix the spell checker first since I think that I might have a chance to save the old added words before trying to fix the other problems.

Reload all my words is a survivable problem but I like to avoid if possible.

Thank you for your help, Mark

  • I am not sure what you can do other then to file a bug report. – Panther Jul 9 '14 at 16:06
  • 1
    Does this actually happen in "all the applications"? Or just LibreOffice? Different programs use different dictionaries. – Aibara Jul 14 '14 at 18:58
  • 1. espell, I think 2. programs are the ones that keep them, check ~/.config 3. no. – Braiam Jul 14 '14 at 21:05
1

Regardless of spell checking tool (libreoffice uses hunspell) the new words are added in standard.dic by libreoffice.

In 14.04 this file is in $HOME/.config/libreoffice/4/user/wordbook/standard.dic

I am guessing that in 12.04 since libreoffice was at version 3.x so the file might be in $HOME/.config/libreoffice/3/user/wordbook/standard.dic

Or if not there you can search for standard.dic in your home. From terminal: cd && find . -name standard.dic

Its possible that the format of the file changed between 3.x and 4.x versions, or when moving to 4.x the profile did not correctly copy over standard.dic. In that case you should be able to find the words in 3.x standard.dic and copy them over to 4.x version in the location mentioned above.

  • @user3633592 since this was useful to fix your problem, please file a bug in libreoffice or ubuntu package. Do check for any existing similar bug report. – sumwale Jul 16 '14 at 7:41
  • The format of standard.dic did, indeed, change between LibreOffice 3 and LibreOffice 4 (LO 4). However, it is possible to open the old LibreOffice 3 standard.dic with LO 4 Writer, after a fashion. You'll see a few strange separator characters, such as hash-signs (#), tabs, page breaks, etc., but you should be able to manually run a spell-check on the file, no matter how messy it looks. Whenever LO 4 finds a word that it doesn't know, select "Add to Dictionary" to save it in the LO 4 standard.dic. – Andrew P. Feb 3 '15 at 5:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.