0

I had Windows 7 and Ubuntu running on a Dual Boot in my Dell Laptop. I formatted it yesterday to do a clean install of both operating systems. I deleted all the operating system partitions. Here's what I did:

  1. Created a new partition and installed Windows 7.
  2. Booted into the Ubuntu Live Disk and selected "Something Else".
  3. I had 3 partitions:

    /dev/sda1 - fat32 - Recovery Partition || /dev/sda2 - ntfs - System Reserved || /dev/sda3 - ntfs - Windows 7 || free space

  4. I clicked on "Add" in order to create the /boot partition. I selected Primary and ext4.

  5. The next moment I find my free space being marked as unusable.

Now, I've always had this layout while dual installing Windows 7 and Ubuntu. And I am pretty sure I selected Primary while creating the /boot partition. And things have worked out pretty well.

But this time, if I follow the same steps, it marks the remaining free space as unusable. I had to proceed by making all the linux paritions (/boot, /, /home) as Logical. Ubuntu installed correctly, but now when I start up, I am presented with the Linux operating select screen.

I mean I don't get this screen, which is quite understandable since I didn't have the /boot partition as Primary : Boot Screen

I get a screen similar to this from where I can select Windows or Ubuntu: enter image description here

My question is why am I blocked if I select /boot as Primary. It worked fine earlier, but now it doesn't.

0

the point is that in hard disks with MBR you can only create four primary partitions. To create extra partitions, you need to have logical partitions. Hence the trouble. on the other hand using GPT, you can make a lot of partitions. I can only assume that you've had GPT before.

  • Hi, I followed this exact same steps earlier in the very same laptop. They worked without a single hiccup. However, this time it failed. Also, MBR can have four partitions I understand that, but in my case the /boot partition was supposed to be the last (4th) primary partition and the rest were to be logical. So why did the unusable thing come up? – Anupam Jul 9 '14 at 8:58
  • you said the problem yourseld. all the others were supposed to be logical. which means that your windows partition before was logical and now is primary. – aveemashfaq Jul 9 '14 at 9:03
  • Hi, I meant the primary partitions were as : Recovery Partition, System Reserved and Windows OS. So, that makes 3, leaving me with 1 remaining. So if I use that 1 for the /boot partition (which I was creating first among all other linux partitions), why would I be restricted from created the remaining /, /home and swap as logical partitions? That is where my question lies. I am following the 4 primary partition law. Also, how did it work earlier in the same laptop? – Anupam Jul 9 '14 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.